Bug 209503 - CD1 fails to boot if there's a hole in memory at 15M
CD1 fails to boot if there's a hole in memory at 15M
Status: CLOSED DUPLICATE of bug 210005
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: syslinux (Show other bugs)
5.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-05 13:26 EDT by Robert Manchek
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-31 14:55:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to prevent the problem (1.90 KB, patch)
2006-10-31 14:26 EST, Robert Manchek
no flags Details | Diff

  None (edit)
Description Robert Manchek 2006-10-05 13:26:50 EDT
Description of problem:
On system where E820 reports reserved memory at 15M (but usable after that),
isolinux loads kernel image and ramdisk into first 15M of memory.  When kernel
boots, it uncompresses, clobbering the ramdisk.

Version-Release number of selected component (if applicable):
3.11-3

How reproducible:
100%

Steps to Reproduce:
1.Find machine with E820 table that reserves memory at ~15M
2.Boot CD1
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Robert Manchek 2006-10-31 14:26:21 EST
Created attachment 139891 [details]
Patch to prevent the problem
Comment 2 Andrius Benokraitis 2006-10-31 14:55:32 EST

*** This bug has been marked as a duplicate of 210005 ***

Note You need to log in before you can comment on or make changes to this bug.