Bug 20955 - extracting embedded fonts doens't work with German locale
Summary: extracting embedded fonts doens't work with German locale
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: acroread   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-16 15:06 UTC by Karsten Weiss
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-16 15:16:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Karsten Weiss 2000-11-16 15:06:38 UTC
Hi!

acroread 4.05-6 has problems with the extraction of fonts embedded in pdf
documents when running in a German locale environment (i.e. LANG=de_DE
and probably others, too). The pop-up error message is

	"Unable to extract embedded font [foobar]".

Fix: Reset the locale environment for the acrobat process by setting it
to "C" :

--- /usr/bin/acroread.originalrh70      Wed Nov 15 22:45:49 2000
+++ /usr/bin/acroread   Wed Nov 15 22:46:41 2000
@@ -1,6 +1,7 @@
 #!/bin/sh
 #
 
+export LANG=C
+export LC_ALL=C
 ver=4.0
 install_dir=/usr/lib/acroread/Reader  

bye,
  Karsten

BTW: I was told that the German default installation of Red Hat 7.0
(I did an upgrade myself) does set LC_ALL in /etc/sysconfig/i18n, too.
IMHO this is unnecessary and rather causes problems.
Setting LANG=de_DE is enough to have correct German locale
support.

Comment 1 Ngo Than 2000-11-16 15:16:11 UTC
i can't reproduce it on my local machine. 
Could you please attach me a pdf file, which causes this problem


Comment 2 Ngo Than 2001-01-04 14:23:16 UTC
in dist-7.1 we moved acroread from powertools to application CD, and so we don't
support it anymore.


Note You need to log in before you can comment on or make changes to this bug.