Bug 209555 - [labeled networking] NetLabel generates the wrong packet context
Summary: [labeled networking] NetLabel generates the wrong packet context
Status: CLOSED DUPLICATE of bug 210032
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 5.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Eric Paris
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-05 22:53 UTC by Paul Moore
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-11 14:23:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul Moore 2006-10-05 22:53:27 UTC
Description of problem:
Discussion on the netdev and SELinux mailing lists on 10/4/2006 revealed that
the method NetLabel uses to generate packet contexts was incorrect.  The
following patch, submitted as a bugfix to the current net-2.6 git tree, fixes
this problem:

 * http://marc.theaimsgroup.com/?l=linux-netdev&m=116008785909601&w=2

Version-Release number of selected component (if applicable):
All kernels which include NetLabel.

How reproducible:
N/A

Steps to Reproduce:
1. N/A
2. 
3.
  
Actual results:
N/A

Expected results:
N/A

Additional info:
This directly effects the LSPP efforts of RH, HP, and IBM.

Comment 1 Paul Moore 2006-10-11 14:17:07 UTC
I see that several of the other NetLabel bugfixes have made it into
kernel-2.6.18-1.2725.el5, what is the status of the bug?

Comment 2 Eric Paris 2006-10-11 14:23:11 UTC
whoops, my fault, forgot about this bug and opened a new one.

*** This bug has been marked as a duplicate of 210032 ***


Note You need to log in before you can comment on or make changes to this bug.