Bug 2095579 - etcdHighNumberOfFailedGRPCRequests alerts with wrong results
Summary: etcdHighNumberOfFailedGRPCRequests alerts with wrong results
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.10
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.10.z
Assignee: Dean West
QA Contact: ge liu
URL:
Whiteboard:
: 2068973 (view as bug list)
Depends On: 2092395
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-06-09 21:56 UTC by OpenShift BugZilla Robot
Modified: 2022-07-11 15:28 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-07-11 15:27:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-etcd-operator pull 850 0 None open [release-4.10] Bug 2095579: etcdHighNumberOfFailedGRPCRequests alerts with wrong results 2022-06-29 13:26:56 UTC
Red Hat Knowledge Base (Solution) 6964544 0 None None None 2022-06-30 08:07:22 UTC
Red Hat Product Errata RHBA-2022:5513 0 None None None 2022-07-11 15:28:11 UTC

Description OpenShift BugZilla Robot 2022-06-09 21:56:22 UTC
+++ This bug was initially created as a clone of Bug #2092395 +++

etcdHighNumberOfFailedGRPCRequests does not honor the low pass filter in the denominator of the promql query. This causes the result to be matched wildly against a wrong set of grpc methods and instances and causes false positive alerts.

more info on slack: https://coreos.slack.com/archives/C0VMT03S5/p1654081131243659

Comment 1 Thomas Jungblut 2022-06-30 08:07:23 UTC
*** Bug 2068973 has been marked as a duplicate of this bug. ***

Comment 6 errata-xmlrpc 2022-07-11 15:27:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.10.22 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:5513


Note You need to log in before you can comment on or make changes to this bug.