Bug 209560 - Missing build dependency: gcc-c++
Missing build dependency: gcc-c++
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gmime (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-05 19:52 EDT by Bernard Johnson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-06 02:25:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernard Johnson 2006-10-05 19:52:21 EDT
Description of problem:
Unless gcc-c++ is installed, the build will fail because it can't find cc1plus.

Version-Release number of selected component (if applicable):
gmime-2.2.3

How reproducible:
Always

Steps to Reproduce:
1.  Remove gcc-c++
2.  rpmbuild -ba gmime.spec
3.
  
Actual results:
<... deleted ...>
checking how to run the C++ preprocessor... /lib/cpp
configure: error: C++ preprocessor "/lib/cpp" fails sanity check
See `config.log' for more details.
error: Bad exit status from /home/bjohnson/rpms/tmp/rpm-tmp.84327 (%build)
    Bad exit status from /home/bjohnson/rpms/tmp/rpm-tmp.84327 (%build)


Expected results:
Successful compile.

Additional info:
Comment 1 Alexander Larsson 2006-10-06 02:25:45 EDT
/lib/cpp is not c++ related. Its the C preprocessor.
And, its in the minimal set apps don't have to buildrequire (gcc requires it).
Anyway, configure finds it, but it fails, so its either a local setup issue at
your place or a cpp bug.
Comment 2 Bernard Johnson 2006-10-06 02:52:20 EDT
Actually, even though it says it is a /lib/cpp problem it wants cc1plus (this is
in the config.log), which is in gcc-c++.  I didn't think gcc-c++ was on the
minimal build environment package list (looking at FE here), but I was wrong. 
I'll assume that FC is the same.
Comment 3 Alexander Larsson 2006-10-06 03:21:22 EDT
Well, it has to be, because it built in the buildsystem, and that only uses
minimal reqs + build reqs.

Note You need to log in before you can comment on or make changes to this bug.