Bug 209597 - sendmail vs /etc/hosts IPv6 local address
Summary: sendmail vs /etc/hosts IPv6 local address
Status: CLOSED DUPLICATE of bug 211800
Alias: None
Product: Fedora
Classification: Fedora
Component: sendmail   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-06 10:40 UTC by David Howells
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-24 15:30:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Howells 2006-10-06 10:40:03 UTC
sendmail as configured by a fresh install binds its listening port to the IPv4 
local address, but does not bind a listening port to the IPv6 local address:

   warthog>netstat -ta | grep 'smtp\|submission'
   tcp        0      0 localhost.localdomain:smtp  *:*           LISTEN      

However, the /etc/hosts file is installed with only an IPv6 local address 
contained therein:

   # Do not remove the following line, or various programs                         
   # that require network functionality will fail.                                 
   ::1     localhost.localdomain   localhost

And there was no IPv4 line.  This means that programs that want to talk to the 
SMTP port on the local host can't because the /etc/hosts file says to use 
IPv6, but sendmail is listening on IPv4.

Comment 1 Tobias Oed 2006-11-23 22:43:25 UTC
This is a dup of bug 211800
Tobias


Comment 2 Matthew Miller 2007-04-06 16:36:12 UTC
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]


Comment 3 Thomas Woerner 2007-07-24 15:30:29 UTC

*** This bug has been marked as a duplicate of 211800 ***


Note You need to log in before you can comment on or make changes to this bug.