Bug 20960 - Need to fix behavior of ctrl:nocaps or ctrl:swapcaps
Summary: Need to fix behavior of ctrl:nocaps or ctrl:swapcaps
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Brent Fox
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-16 16:22 UTC by Michael McConachie
Modified: 2013-09-02 05:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-08 21:34:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael McConachie 2000-11-16 16:22:23 UTC
The anaconda generated  XF86Config-4 file has the commented lines:

# If you'd like to switch the positions of your capslock and
# control keys, use: 
#       Option  "XkbOptions"    "ctrl:nocaps"

Instead of swapping the capslock and ctrl key, this seems to have no effect
at all in XFree86 4.0.1.  Using "ctrl:swapcaps" results in the behavior
indicated by the comment.



     --gleep

Comment 1 Mike A. Harris 2000-11-25 09:55:20 UTC
Is this using GUI install, or text mode install?


Comment 2 Trond Eivind Glomsrxd 2000-11-26 04:55:08 UTC
This would be an anaconda problem

Comment 3 Michael McConachie 2000-11-27 16:14:19 UTC
GUI installs were used. 

Later,
	--gleep


Comment 4 Brent Fox 2000-12-04 19:58:28 UTC
I'm not sure I understand the problem.  If the line is commented out, no change
will take place.  That is, the caps lock key behaves like the caps lock key and
the Ctrl key behaves like the Ctrl key. In my experiments, the line:
      Option  "XkbOptions"    "ctrl:nocaps"
causes the caps lock key to behave like the Ctrl key.  The Ctrl key behavior is
unchanged.  Then, the line:
      Option  "XkbOptions"    "ctrl:swapcaps"
causes the caps lock key and the Ctrl key to swap behavior.  

So, I was unable to reproduce this bug.  Also, this bug is related to X...not
the installer.  I'm inclined to think that this is not a bug, but I'm
transferring it to mharris to verify that this is the case.

Comment 5 Michael McConachie 2000-12-04 21:47:59 UTC
The problem isn't in what the Option line does with the X server, but more in
that the instructions we are giving people that read the file does not match the
command we are giving them.  Ie: if they want to go ahead and switch the CTRL
and Caps Lock key they will need to use ctrl:swapcaps.  ctrl:nocaps results in a
different behavior than what the comment instructs.

Which, ahh, I didn't really say... But it's what I meant.  Honest.  :)

I think that either the comment should be taken out entirely, the comment made
to match the behavior of the option, or the option changed to match the behavior
specified in the comment.

Kinda nitpicky, I know, but we've actually been getting install support calls on
this little item.

Later,

	--gleep


Comment 6 Mike A. Harris 2000-12-05 10:45:04 UTC
Reassigned to component owner.


Comment 7 Brent Fox 2000-12-08 19:49:23 UTC
Ok, how about if I change the file so that it looks like this:

# If you'd like to switch the positions of your capslock and
# control keys, use:
#    XkbOptions  "ctrl:swapcaps"
#
# If you'd like to disable the capslock key, use:
#    XkbOptions  "ctrl:nocaps"

That way, they get instructions on how to do both.  Is that ok?


Comment 8 Michael McConachie 2000-12-08 21:30:31 UTC
Looks great to me.  That should keep everyone happy, thanks!

	--gleep



Note You need to log in before you can comment on or make changes to this bug.