Bug 209601 - wish there was a non-PAE Xen kernel
Summary: wish there was a non-PAE Xen kernel
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel-xen   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Xen Maintainance List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-06 11:17 UTC by Russell Coker
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-06 13:12:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Russell Coker 2006-10-06 11:17:11 UTC
The kernel-xen package is compiled with PAE support.  This means that machines 
such as my Pentium-M laptop can not run Xen.

Comment 1 Daniel Berrange 2006-10-06 13:12:18 UTC
There is a very tricky situation with Xen on i386 & PAE. You basically have to
have a matched stack, either all PAE, or all non-PAE - you can't mix & match. 
Since PAE is needed for machines with > 4 GB ram, and all current CPUs do now
have PAE (even current laptop targetted CPUs), in FC6 the decision was made to
go for PAE kernels. Unfortunately this excludes some older laptops without PAE.


Comment 2 Vedran Miletić 2006-10-13 17:47:38 UTC
Does matched stack mean that you need to compile all xen-relevant packages
compiled with or without PAE support? If that's the case, then I understand the
decision, but if it's not, then it would be better to have kernel-xen and
kernel-xenPAE instead of what we currently have.

Comment 3 Stephen Tweedie 2006-10-13 18:09:38 UTC
No, it's only the kernel-xen package that matters (that package includes both
the kernel and the hypervisor, which are the only two components that care about
PAE status.)  But the PAE choice in paravirtualised guests MUST match that in
the dom0 host.



Note You need to log in before you can comment on or make changes to this bug.