This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 209626 - scim doesn't show preedit text from fallback context
scim doesn't show preedit text from fallback context
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: scim-bridge (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peng Huang
: i18n, MoveUpstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-06 10:07 EDT by Matthias Clasen
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-09 00:30:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2006-10-06 10:07:19 EDT
The gtk input context implementation in scim-bridge uses a GtkIMContextSimple as
a "fallback" context, but it does not show preedit text from that fallback context.

Try the following: 

1) enable scim
2) hold control-shift
3) type u123
4) releaes control-shift
5) by surpised by an accented g popping up

Notice that there is no preedit text displayed in 3)
Comment 1 Ryo Dairiki 2006-10-08 02:54:27 EDT
This is the feature of SCIM itself.
Please try "export GTK_IM_MODULE=scim; gedit" from the terminal.
You can confirm that exactly the same thing happens.
If you're annoying by this feature, please report this to SCIM project directly.
Comment 2 Matthias Clasen 2006-10-08 09:39:12 EDT
This is not a feature, it is a bug
Comment 3 Jens Petersen 2006-10-16 02:13:01 EDT
Okay, but I think Dairiki-san means it is not a regression relative to
the scim gtkimm.
Comment 4 Jens Petersen 2006-10-18 01:22:47 EDT
Reproduced for both scim and scim-bridge.

Since scim provides the rawcode engine for unicode input (currently hidden by
default though in Fedora), perhaps it would be better if it didn't pass the
Ctrl-Shift-U event to GtkIMContextSimple.
Comment 6 Hu Zheng 2007-01-31 00:46:16 EST
I think Ctrl-Shift-U should not be the feature of scim, but the feature of
gtk(or x-window?), so the preedit window won't shown as scim don't know this at all.
Ctrl-Shift-U work even when scim is not running(or be killed).
If you want to see the preedit window, just choose scim's rawcode im engine,
then enter 123 and the preedit window will be shown, the first character is just
what you input by Ctrl-Shift-U with 123.
So this is not a bug.
Comment 7 Matthias Clasen 2007-01-31 09:42:31 EST
Well, if scim uses some other input method as fallback (like in thie case
GtkIMContextSimple), it better made sure that any preedit text of the fallback
input method finds its way back to the application. It doesn't, and thats a bug.
Comment 8 Peng Huang 2007-05-23 20:09:55 EDT
I think the best way to fix this bug by disabling this feature, but GtkIMContext
does not provide an interface to do it. It is difficult to disable it in scim
and scim-bridge. I suggest asking gtk to add this API.
Comment 9 Matthias Clasen 2007-05-23 20:22:44 EDT
No, this is an scim bug. If it decides to fallback to GtkImContextSimple, it
needs to do it properly.
Comment 10 Matthias Clasen 2007-05-23 20:23:48 EDT
And if it cannot be bothered to do it properly, it should not do the fallback
Comment 11 Peng Huang 2007-05-23 22:02:39 EDT
Yeah. It's an bug in scim. But it is difficult fix without an API to disable it
in GTK. I found other IMs have similar problem, like uim.
I do not suggest showing preedit text from GtkIMContextSimple, it will conflict
with own preedit text.
Comment 12 Matthias Clasen 2007-05-23 22:04:42 EDT
It is very simple - if you cannot display preedit text from the fallback, then
don't fallback to something that produces preedit text...
Comment 13 Peng Huang 2007-05-23 22:18:37 EDT
Do you mean discarding Ctrl+Shift+U key event?
Comment 14 Matthias Clasen 2007-05-23 22:34:16 EDT
I mean just don't fall back to GtkImContextSimple. But filtering out C-S-u may
be good enough.
Comment 15 Peng Huang 2007-06-06 05:43:31 EDT
Fixed in scim-bridge-0.4.12-3.fc8.
Comment 16 A S Alam 2007-09-17 00:44:27 EDT
try to reproduce and test with latest version.
use gedit, use scim-bridge- > Press Ctrl+Shift+U+012-> No pre-edit buffer
ctrl-Space (deactivate Scim) - >press Ctrl+Shift+U+012->Showing Preedit buffer.
it seems bug still present with scim-bridge.
can someone please have a look and help to correct me with stop I used to produce.


Version:scim-1.4.7-3.fc8
Comment 17 Jens Petersen 2007-10-08 21:56:09 EDT
Does "Control+Shift+u123" still work in current rawhide?

(It doesn't seem to do anything for me anymore.)
Comment 18 Jens Petersen 2007-10-08 22:07:34 EDT
Hmm nevermind, probably it is a local issue on my test machine:
it works for me on another rawhide install (without scim).
Comment 19 Jens Petersen 2007-10-09 00:29:25 EDT
"C-S-u123" preedit works for me under scim-bridge on a fresh japanese install
of rawhide.  So this looks good to me now. :)
Comment 20 Jens Petersen 2007-10-09 00:30:51 EDT
(In reply to comment #16)
> use gedit, use scim-bridge- > Press Ctrl+Shift+U+012-> No pre-edit buffer
> ctrl-Space (deactivate Scim) - >press Ctrl+Shift+U+012->Showing Preedit buffer.

This only needs to work when scim is deactivated so that is ok.
Thanks for testing. :)

Note You need to log in before you can comment on or make changes to this bug.