Bug 209643 - Should gray out Card Removal Action=Lock if gnome-screensaver not installed
Summary: Should gray out Card Removal Action=Lock if gnome-screensaver not installed
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: authconfig   
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-06 16:14 UTC by Jeff Needle
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-18 15:31:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeff Needle 2006-10-06 16:14:02 UTC
I am using xscreensaver with a smart card.  I checked "Authentication->Enable
Smart Card Support" and chose "Lock" for Card Removal Action, but if
xscreensaver is installed, it takes precedence over gnome-screensaver.  We
should probably check to see if gnome-screensaver is enabled as the default or
else not offer that as a choice.

Comment 1 Tomas Mraz 2006-10-06 16:26:22 UTC
Ray, is there some easy and reliable way how to get this information whether
gnome-screensaver will be in effect?

I'm afraid there isn't because it is configurable per user but the authconfig
setting is system-wide. IMO we could just check whether gnome-screensaver
is/isn't installed looking for the /usr/bin/gnome-screensaver binary. But then
xscreensaver probably at least shouldn't take precedence over gnome-screensaver
when it is simply installed and user session configuration is not modified.


Comment 2 Ray Strode [halfline] 2006-10-06 17:09:59 UTC
so we actually just do this:
        if ((ss_command = g_find_program_in_path ("gnome-screensaver")))
                use_gscreensaver = TRUE;
        else {
                if (!(ss_command = g_find_program_in_path ("xscreensaver")))
                        return FALSE;
        }
Which is probably backwards, since if the user installs xscreensaver they
probably want to use it without having to uninstall gnome-screensaver, but
anyway, the upshot is you can just test for its existance.  

Comment 3 Tomas Mraz 2006-10-06 17:47:45 UTC
Just for curiousness is it possible to override the behaviour from comment #2 by
user?


Comment 4 Ray Strode [halfline] 2006-10-06 18:03:20 UTC
Nope.

Comment 5 Ray Strode [halfline] 2006-10-06 18:39:56 UTC
Note this bug isn't really a big deal for RHEL5, because we don't ship
xscreensaver in RHEL anymore.

Comment 6 Jeff Needle 2006-10-06 18:48:35 UTC
Yeah, this is low priority/low severity for a reason.  I probably should have
reported it against rawhide.

Comment 7 Tomas Mraz 2007-07-18 15:31:53 UTC
Fixed in authconfig-5.3.15


Note You need to log in before you can comment on or make changes to this bug.