Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Description of problem:
[Machines] Can not create vm with Cloud base image with only user name/password configured
Packages:
cockpit-machines-268-1.el9.noarch
cockpit-269-1.el9.x86_64
libvirt-8.4.0-1.el9.x86_64
virt-install-3.2.0-14.el9.noarch
How reproducible:
100%
Steps:
1 Prepare a cloud image like:
rhel-guest-image-9.0-20220420.0.x86_64.qcow2
2 Click "Create VM", on Details tab, configure as following:
Installation type: "Cloud base image"
Installation source: the image file prepared in step1
Operating system:Red Hat Enterprise Linux 9 Unknown (9-unknown Plow)
3 Click Automation tab, configure as following:
User login:test123
User password:test123redhat
Leave "Root password" field as blank, click "Create and run"
Actual results:
The vm failed to create with error like:
Creation of VM rhel9-unknown-2022-6-13-C failed
ERROR rhel9-unknown requires the admin-password to be set. Domain installation does not appear to have been successful. If it was, you can restart your domain by running: virsh --connect qemu:///system start rhel9-unknown-2022-6-13-C otherwise, please restart your installation.
Expected results:
The vm can be created successfully in step 3 without Root password setted.
Additional info:
I tried virt-install --cloud-init, the vm can be created but the password was not passed to the vm correctly:
# cat cloudinit-user-data.yaml
users:
- test123
chpasswd:
list: |
test123:test123redhat
expire:
False
# virt-install --name rhel-guest-image-1 --memory 4096 --import --disk /images/rhel-guest-image-9.0-20220420.0.x86_64.qcow2 --cloud-init user-data=cloudinit-user-data.yaml --noautoconsole
Verified with packages:
cockpit-machines-273-1.el9.noarch
cockpit-275-1.el9.x86_64
libvirt-dbus-1.4.1-5.el9.x86_64
libvirt-daemon-8.5.0-5.el9.x86_64
Steps:
1 Prepare a cloud image like:
rhel-guest-image-9.0-20220420.0.x86_64.qcow2
2 Click "Create VM", on Details tab, configure as following:
Installation type: "Cloud base image"
Installation source: the image file prepared in step1
Operating system:Red Hat Enterprise Linux 9 Unknown (9-unknown Plow)
3 Click Automation tab, configure as following:
User login:test123
User password:test123redhat
Leave "Root password" field as blank, click "Create and run"
The vm can be created successfully and log into the vm, the user name and password can work.
So verified.
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.
For information on the advisory (cockpit-machines bug fix and enhancement update), and where to find the updated
files, follow the link below.
If the solution does not work for you, open a new bug report.
https://access.redhat.com/errata/RHBA-2022:8094
Description of problem: [Machines] Can not create vm with Cloud base image with only user name/password configured Packages: cockpit-machines-268-1.el9.noarch cockpit-269-1.el9.x86_64 libvirt-8.4.0-1.el9.x86_64 virt-install-3.2.0-14.el9.noarch How reproducible: 100% Steps: 1 Prepare a cloud image like: rhel-guest-image-9.0-20220420.0.x86_64.qcow2 2 Click "Create VM", on Details tab, configure as following: Installation type: "Cloud base image" Installation source: the image file prepared in step1 Operating system:Red Hat Enterprise Linux 9 Unknown (9-unknown Plow) 3 Click Automation tab, configure as following: User login:test123 User password:test123redhat Leave "Root password" field as blank, click "Create and run" Actual results: The vm failed to create with error like: Creation of VM rhel9-unknown-2022-6-13-C failed ERROR rhel9-unknown requires the admin-password to be set. Domain installation does not appear to have been successful. If it was, you can restart your domain by running: virsh --connect qemu:///system start rhel9-unknown-2022-6-13-C otherwise, please restart your installation. Expected results: The vm can be created successfully in step 3 without Root password setted. Additional info: I tried virt-install --cloud-init, the vm can be created but the password was not passed to the vm correctly: # cat cloudinit-user-data.yaml users: - test123 chpasswd: list: | test123:test123redhat expire: False # virt-install --name rhel-guest-image-1 --memory 4096 --import --disk /images/rhel-guest-image-9.0-20220420.0.x86_64.qcow2 --cloud-init user-data=cloudinit-user-data.yaml --noautoconsole