Bug 209654 - anaconda error with IPv4 address data for static ip
anaconda error with IPv4 address data for static ip
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
ppc64 Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-06 13:34 EDT by Mark Smith
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-06 15:16:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark Smith 2006-10-06 13:34:18 EDT
Description of problem:
Correct static IPv4 network address is flagged as invalid.

Version-Release number of selected component (if applicable):
Oct6 snapshot of rawhide

How reproducible: easy


Steps to Reproduce:
1. netboot ppc64 system (I used yaboot)
text install mode
power5 system has Veth for eth0, Vscsi client disks: sda, sdb
configure eth0 as static and point to nfs://rhlte/distros/rawhide_snap/ dir
2. anaconda will start. accept default partitioning offered (doesn't seem to
matter).
3. when eth0 config menu is offered, accept defaults offered (is same as when I
config'd it to start the nfs install):
dhcp: not selected
ipv4: selected
ipv6: not selected
activate on boot: selected
correct static ipv4 and netmask are offered.
click ok and anaconda errors:
 Error with IPv4 address Data
and in popup window:
 '9.3.117.236' is an invalid IP address 
  
This has been seen on rawhide since May 2006:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=192115
however the workaround in that bug no longer succeeds(unselect 'activate on
boot' to proceed and fix activate after install completes)

Now the workaround is to leave activate on boot selected, leave the static ipv4
information in tact, but select the 'dhcp' option too.

Actual results:
cannot install with static ipv4 address activated

Expected results:
successful install

Additional info:
Comment 1 David Cantrell 2006-10-06 15:16:34 EDT
OK, found the problem.  Line 91 of network.py in the sanityCheckIPString
function.  I did this:

if ip_string.find(':') == -1 and ip_string.find('.') > 1:

When I really meant to do this:

if ip_string.find(':') == -1 and ip_string.find('.') > 0:

Whoops.  Fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.