Bug 20970 - Stale DNS connections
Summary: Stale DNS connections
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-16 18:29 UTC by daryl herzmann
Modified: 2007-04-18 16:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-20 16:56:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description daryl herzmann 2000-11-16 18:29:23 UTC
When I do a netstat on my RH 7 box.  I receive a listing of many
connections to my DNS server.

....
udp        0      0 mybox:3236 ns-1.iastate.edu:domain
ESTABLISHED 
udp        0      0 mybox:3235 ns-2.iastate.edu:domain
ESTABLISHED 
udp        0      0 mybox:3234 ns-3.iastate.edu:domain
ESTABLISHED 
....

This listing continues to grow and grow and grow...

Comment 1 daryl herzmann 2000-11-27 19:09:47 UTC
Follow-Up:

This should be filed under apache.  The excessive listing of stale connections
disappears once I restart apache.  I just installed the latest patches and will
try to compile the latest apache version again...

Comment 2 daryl herzmann 2000-12-08 18:11:29 UTC
Ok, 
	I am now running hand compiled apache binaries and this 'problem' still
occurs.  I can make the excessive listing of connections go away by restarting
apache.



Comment 3 Pekka Savola 2000-12-28 23:00:07 UTC
Out of curiousity: you have 'HostnameLookups On' in your httpd.conf, right?  Does this behaviour 
change if you reverse it?



Comment 4 daryl herzmann 2001-01-05 12:04:27 UTC
I do have HostnameLookups On and unfortunately, this machine is a production
server, so I hesitate to test this by changing it and ruin the access logs for
the time.  Honestly, my main fight with the server has been to keep the machine
up with a stable  kernel, aughhhh...

Thanks for the suggestion and I will try it out, but I think that I am
downgrading to RH 6.2 for something stable.

Crashes
RH 6.0   -> 2
RH 6.2   -> 0
RH 7.0   -> 23

Comment 5 Pekka Savola 2001-01-06 21:50:05 UTC
Hmm.  Are you also running a DNS server on the system, or resolving the addresses
directly?  If possible, try without using DNS, as this might be a problem with Bind too.  
There have been reports of weird behaviour in the past.


Comment 6 daryl herzmann 2001-01-10 17:53:42 UTC
Thanks for the continued help!

Ok, the DNS server is the Universities and I am assuming that nothing is wrong
with it, since it serves 20,000 other computers on campus without a problem :)

My /etc/resolv.conf looks like
search agron.iastate.edu
nameserver 129.186.142.200
nameserver 129.186.1.200
nameserver 129.186.140.200

I should try recompiling apache with the new gcc and see what happens.

I think that this problem is an annoyance more than anything.  I just restart
apache every two days and the DNS connections go away as reported by netstat.

I upgraded to 2.2.18 kernel and the server has yet to crash, knock on wood.
Thanks

Comment 7 daryl herzmann 2001-01-20 16:56:54 UTC
Ok,
	Who knows what the problem was, but it has stopped since I updated to
glibc-2.2-12  ...  Just another RH7 oddity.  Kernel 2.4.0 has also kept my
machine up for a week now, which is the longest run since I upgraded to RH7. 
Life is good again.  Thanks for the time.


Note You need to log in before you can comment on or make changes to this bug.