Bug 20971 - makedepend problems with C++ files
Summary: makedepend problems with C++ files
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-16 18:42 UTC by mgross
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-25 22:17:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description mgross 2000-11-16 18:42:27 UTC
I know that makedepend comes as part of the XFree86-devel package, but that
did not seem like the appropriate place for this bug.

If I run makedepend on C++ files with a .cc extension, it spits out
dependencies in the form:

file..o: foo
file..o: bar
etc, etc

If I rename the file file.c and run makedepend, I get
file.o: foo
file.o: bar
etc, etc

So it looks like there is some error in the pattern matching for .cc files.
Maybe it is just looking for the last c and replacing it and the character
before it with a .o

Thanks,
Michael Ross
MIT AI Lab

Comment 1 Mike A. Harris 2002-02-01 09:31:56 UTC
I believe someone has fixed this in X sources.  If not however,
please report these types of enhancement requests upstream to
XFree86 directly in the future for faster enhancement/bug
resolution.

4.2.0 in rawhide probably has the droids you're looking for.  ;o)


Note You need to log in before you can comment on or make changes to this bug.