Bug 20974 - nanny leaking file descriptors
Summary: nanny leaking file descriptors
Status: CLOSED ERRATA
Alias: None
Product: Red Hat High Availability Server
Classification: Retired
Component: piranha (Show other bugs)
(Show other bugs)
Version: beta
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Phil Copeland
QA Contact: Phil Copeland
URL:
Whiteboard:
Keywords:
: 53783 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-16 19:04 UTC by Need Real Name
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-03 16:44:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Red Hat Bugzilla 2000-11-16 19:04:05 UTC
when configured to use ruptime, but when the client machines arn't running
the ruptime daemon, nanny failed the connections but apparently doesn't
close the file handle. Eventually
(after afew hours) nanny runs out and dies.

Comment 1 Red Hat Bugzilla 2000-11-20 16:44:37 UTC
Thank you for this report!

We will try to fixed this in an upcoming errata

Comment 2 Red Hat Bugzilla 2001-01-25 07:56:20 UTC
Hi,

I also experienced the problem. The following seemed to have fixed it for me.  
The nanny version is the one that comes with piranha-0.4.17-7.

--- nanny.c.orig        Wed Jan 24 10:53:17 2001
+++ nanny.c     Thu Jan 25 08:58:53 2001
@@ -750,12 +750,14 @@
            logArgv(flags, argv);
            kill(child, SIGKILL);
            waitpid(child, &status, 0);
+            close(p[0]);
            return NULL;
     }

     if (!WIFEXITED(status) || WEXITSTATUS(status)) {
            piranha_log(flags, (char *) "The following exited abnormally:");
            logArgv(flags, argv);
+            close(p[0]);
            return NULL;
     }

@@ -781,7 +783,7 @@
     *argp++ = loadCommand;
     *argp++ = inet_ntoa(*remoteAddr);

-    if (strcmp(loadCommand, (char *) "none"))
+    if (strcmp(loadCommand, (char *) "none") == 0)
        return -1.0; /* nothing to see here, go home silently */

     if (strcmp(loadCommand, (char *) "rup"))


Cheers
Tinus


Comment 3 Red Hat Bugzilla 2001-04-03 16:44:37 UTC
Yeap, that looks sane.
I'll add that into the cvs shortly.

If I get a moment to myself I'l make the rpms as well (bit busy stomping on the
kernel the last while)

Phil
=--=

Comment 4 Red Hat Bugzilla 2001-05-07 19:46:38 UTC
These patches (two "close(p[0])" statements and a " == 0") have been added to
nanny and will appear in an upcoming release, with credit given to tinus.

Users can apply the above patch as a work-around until the new nanny has been
released.



Comment 5 Red Hat Bugzilla 2001-09-23 18:13:52 UTC
*** Bug 53783 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.