Bug 209753 - NetworkManager loops forever if dhcdbd isn't running
Summary: NetworkManager loops forever if dhcdbd isn't running
Status: CLOSED DUPLICATE of bug 204322
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC7Blocker
TreeView+ depends on / blocked
 
Reported: 2006-10-06 20:27 UTC by Paul Dickson
Modified: 2013-01-10 04:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-06 11:34:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul Dickson 2006-10-06 20:27:14 UTC
Description of problem:
NetworkManager loops forever if dhcdbd isn't running, continuously hitting the
hard drive (mostly like logging output).

Version-Release number of selected component (if applicable):
NetworkManager-0.6.4-5.fc6

How reproducible:
Always

Steps to Reproduce:
1. service dhcdbd stop
2. killall NetworkManager
3. NetworkManager --no-daemon
  
Actual results:
<information>     Will activate connection 'eth0'. 
<information>     Device eth0 activation scheduled... 
<information>     Activation (eth0) started... 
<information>     Activation (eth0) Stage 1 of 5 (Device Prepare) scheduled... 
<information>     Activation (eth0) Stage 1 of 5 (Device Prepare) started... 
<information>     Activation (eth0) Stage 2 of 5 (Device Configure) scheduled... 
<information>     Activation (eth0) Stage 1 of 5 (Device Prepare) complete. 
<information>     Activation (eth0) Stage 2 of 5 (Device Configure) starting... 
<information>     Activation (eth0) Stage 2 of 5 (Device Configure) successful. 
<information>     Activation (eth0) Stage 3 of 5 (IP Configure Start) scheduled. 
<information>     Activation (eth0) Stage 2 of 5 (Device Configure) complete. 
<information>     Activation (eth0) Stage 3 of 5 (IP Configure Start) started... 
<WARNING>  nm_dhcp_manager_begin_transaction (): dhcdbd not running! 
<information>     Activation (eth0) failure scheduled... 
<information>     Activation (eth0) Stage 3 of 5 (IP Configure Start) complete. 
<information>     Activation (eth0) failed. 
<information>     Deactivating device eth0. 
<information>     SWITCH: no current connection, found better connection 'eth0'. 
<WARNING>  nm_dhcp_manager_get_state_for_device (): dhcdbd not running! 


Expected results:
I would like NetworkManager to somehow notify me of a problem rather than looping.

Additional info:

Comment 1 Tom London 2006-10-27 13:38:43 UTC
NetworkManager-0.6.5-0.cvs20061025.fc7 removes the code to start dhcdbd in
/etc/init.d/NetworkManager, causing this situation.

Should dhcdbd be started before NetworkManager, or should this revert back?

tom

--- /tmp/NetworkManager 2006-10-27 06:32:04.000000000 -0700
+++ ./NetworkManager    2006-10-24 22:35:42.000000000 -0700
@@ -36,11 +36,6 @@
 {
        echo $"Setting network parameters... "
        sysctl -e -p /etc/sysctl.conf >/dev/null 2>&1
-
-       if [ ! -e /var/lock/subsys/dhcdbd ]; then
-               service dhcdbd start
-       fi
-
        echo -n $"Starting NetworkManager daemon: "
        daemon --check $servicename $processname --pid-file=$pidfile
        RETVAL=$?

Comment 2 Paul Dickson 2006-10-27 15:28:43 UTC
In my case, the services had been setup, but not made to start when the init
level changed.  So when I started NetworkManager from the command line (as
root), the service dhcdbd was not running.  This condition should be handled or
the rpms should add the up levels and start the service when they are installed.

Comment 3 Jesse Keating 2007-01-20 16:56:50 UTC
Also, its not clear that when you enable the NetworkManager service you ALSO
have to enable the dhcdbd service.  And unlike before, one can't just start
NetworkManager and use it, now one has to start NetworkManager _and_ dhcdbd. 
This should be fixed before Test1.



Comment 4 Charles R. Anderson 2007-02-28 18:27:32 UTC
This isn't fixed in development as of 2/26/2007.

dhcdbd-2.5-1.fc7
Build Date: Thu 08 Feb 2007 10:41:24 AM EST

NetworkManager-0.6.5-0.3.cvs20061025.fc7
Build Date: Thu 08 Feb 2007 02:58:56 PM EST


Comment 5 Wade Mealing 2007-03-06 11:30:57 UTC
Yeah, I'm getting it too.

Update from fc6->rawhide, this service was not configfured to run on start. 

Comment 6 Wade Mealing 2007-03-06 11:34:11 UTC
This looks like a duplicate, just thought i'd save you guys time and close it,
reopen if its not.

*** This bug has been marked as a duplicate of 204322 ***


Note You need to log in before you can comment on or make changes to this bug.