Bug 2097695 - [4.10][BM IPI with Provisioning Network] Worker nodes are not provisioned: ironic-agent is stuck before writing into disks
Summary: [4.10][BM IPI with Provisioning Network] Worker nodes are not provisioned: ir...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Bare Metal Hardware Provisioning
Version: 4.10
Hardware: aarch64
OS: Unspecified
high
high
Target Milestone: ---
: 4.10.z
Assignee: Derek Higgins
QA Contact: aleskandro
URL:
Whiteboard:
: 2098658 2098701 (view as bug list)
Depends On: 2092650
Blocks: 2105345
TreeView+ depends on / blocked
 
Reported: 2022-06-16 10:46 UTC by Mike Fiedler
Modified: 2022-07-20 07:46 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 2092650
Environment:
Last Closed: 2022-07-20 07:46:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift baremetal-operator pull 230 0 None open [release-4.10] Bug 2097695: Stop treating missing network as fatal error 2022-06-30 10:58:44 UTC
Red Hat Product Errata RHBA-2022:5568 0 None None None 2022-07-20 07:46:33 UTC

Comment 1 Derek Higgins 2022-06-30 10:55:27 UTC
*** Bug 2098701 has been marked as a duplicate of this bug. ***

Comment 2 Derek Higgins 2022-06-30 10:55:33 UTC
*** Bug 2098658 has been marked as a duplicate of this bug. ***

Comment 6 aleskandro 2022-07-12 14:35:44 UTC
The fix landed in 4.10 nightlies, but it's not testable as the branch is never covered due to the removal of the networkConfig secret by another micro-service. As stated above, the intent of this backport was to avoid future re-vendoring of other operators to make this bug arise on 4.10.

As this is tested on 4.11 successfully, I'm moving it to verified.

Comment 9 errata-xmlrpc 2022-07-20 07:46:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.10.23 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:5568


Note You need to log in before you can comment on or make changes to this bug.