Bug 20977 - Sendmail queues message which can actually be delivered
Sendmail queues message which can actually be delivered
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: sendmail (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
Dale Lovelace
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-16 14:51 EST by ppinto
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-06 06:46:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ppinto 2000-11-16 14:51:44 EST
When mail is sent using the command line or sendmail -v, mail is sent
correctly.

When netscape connects to sendmail over localhost, all messages are
queued, but never sent until one runs sendmail -q, at which point they
are properly sent on their way.

When

      FEATURE(`accept_unresolvable_domains')

is commented out, the problem disappears.

When one connects to sendmail via port 25, and runs commands by hand,
when one gives the RCPT myname@anothermachine.domain.name command,
it responds that the recipient is ok, and then "will queue".

When the feature (?) is turned off, then everything works as it should (at
least
as I expect it should -- mail is sent).

It is as if it hasn't yet check to see if it can resolve the recipient
domain when the
message is accepted and queued for later delivery, yet if the message is
not accepted
at this point, sendmail goes on to find that the domain can in fact be
resolved and
all is well.
Comment 1 Florian La Roche 2001-08-06 06:45:58 EDT
I can't reproduce this here. It sounds strange that this problem goes away
when disablen accept_unresolvable_domains.

Can you forward me a complete email that is failing/working? Seems to
work fine for me here.

Thanks,

Florian La Roche
Comment 2 Florian La Roche 2002-03-10 03:01:33 EST
Looks all fine to me. Please re-open if you still think sendmail is doing
something wrong here.

Thanks,

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.