Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 2097754

Summary: [OSP17] DCN: The /etc/hosts file on the DCN site nodes is not populated with central site DNS records
Product: Red Hat OpenStack Reporter: Marian Krcmarik <mkrcmari>
Component: python-tripleoclientAssignee: Rabi Mishra <ramishra>
Status: CLOSED ERRATA QA Contact: David Rosenfeld <drosenfe>
Severity: high Docs Contact:
Priority: high    
Version: 17.0 (Wallaby)CC: cjeanner, hbrock, jschluet, jslagle, mburns, oblaut, ramishra
Target Milestone: betaKeywords: Regression, Triaged
Target Release: 17.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-tripleoclient-16.4.1-0.20220626012046.b224e0b.el9ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-09-21 12:22:30 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Marian Krcmarik 2022-06-16 13:05:32 UTC
Description of problem:
If DCN site is deployed without a mechanism to automatically add the DNS records into a DNS server (for example when TLS-E is used with dedicated FreeIPA server) then the deployment of the DCN site would eventually fail due to inability to resolve central site API FQDN endpoints because /etc/hosts file is not populated with DNS records of central site nodes and API endpoints.
This used to be working in some previous OSP17 ds composes but now it seems that " openstack overcloud export" command does not export ExtraHostFileEntries data.

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-14.3.1-0.20220607161058.ced328c.el9ost.noarch
python3-tripleoclient-16.4.1-0.20220607160517.4d2a5db.el9ost.noarch

How reproducible:
always

Steps to Reproduce:
1. Deploy a DCN env without a dedicated FreeIPA server serving as a DNS server.

Actual results:
The deployment of a DCN would fail on:
Nova: Manage aggregate and availability zone and add hosts to the zone | undercloud | error={"changed": false, "extra_data": {"data": null, "details": "Compute host dcn1-compute1-0.redhat.local could not be found.", "response": "{\"itemNotFound\": {\"code\": 404, \"message\": \"Compute host dcn1-compute1-0.redhat.local could not be found.\"}}"}, "msg": "ResourceNotFound: 404: Client Error for url: https://10.0.10.155:13774/v2.1/os-aggregates/5/action, Compute host dcn1-compute1-0.redhat.local could not be found."}

Because rabbitmq endpoint can't be resolved due to missing records in /etc/hosts on the DCN site nodes.

Expected results:


Additional info:
This used to work a couple of months ago

Comment 8 errata-xmlrpc 2022-09-21 12:22:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Release of components for Red Hat OpenStack Platform 17.0 (Wallaby)), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2022:6543