Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 2097879

Summary: OSP17 ceph deploy fails with satellite due to extra slash
Product: Red Hat OpenStack Reporter: David Rosenfeld <drosenfe>
Component: python-tripleoclientAssignee: John Fulton <johfulto>
Status: CLOSED ERRATA QA Contact: David Rosenfeld <drosenfe>
Severity: high Docs Contact:
Priority: high    
Version: 17.0 (Wallaby)CC: bshephar, fpantano, hbrock, johfulto, jschluet, jslagle, mburns, slinaber
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-tripleoclient-16.4.1-0.20220705111519.23dbe54.el9ost Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-09-21 12:22:30 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description David Rosenfeld 2022-06-16 19:59:29 UTC
Description of problem: Overcloud deploy is attempted using a satellite for content. It fails deploying ceph at task: Run cephadm bootstrap

The error occurs executing this command because it returns: Error: invalid reference format:

/bin/podman pull undercloud1702-0.ctlplane.redhat.local:8787//default_organization-ceph4_6_containers-rhceph:5-170
Error: invalid reference format


There is an extra slash in that command between 8787 and default_organization.

This is seen when looking at container images (i.e. the second slash is not there): 

openstack tripleo container image list | grep 5-170
/usr/lib/python3.9/site-packages/ansible/_vendor/__init__.py:42: UserWarning: One or more Python packages bundled by this ansible-core distribution were already loaded (pyparsing). This may result in undefined behavior.
  warnings.warn('One or more Python packages bundled by this ansible-core distribution were already '
| docker://undercloud1702-0.ctlplane.redhat.local:8787/default_organization-ceph4_6_containers-rhceph:5-170

Now try the podman pull without the second slash:

/bin/podman pull undercloud1702-0.ctlplane.redhat.local:8787/default_organization-ceph4_6_containers-rhceph:5-170
Trying to pull undercloud1702-0.ctlplane.redhat.local:8787/default_organization-ceph4_6_containers-rhceph:5-170...
Getting image source signatures
Copying blob 4eef1fa1f1c1 done  
Copying blob 967da9d9d3cf done  
Copying blob eb24191cef20 done  
Copying config 9ea8ac4eae done  
Writing manifest to image destination
Storing signatures
9ea8ac4eae90914d5ea5096dbcf010fc393ce90c3daa94385fc2b017de0629b1



Version-Release number of selected component (if applicable): RHOS-17.0-RHEL-9-20220615.n.2


How reproducible: Every time


Steps to Reproduce:
1. Do an overcloud deploy from a satellite server. The error is seen when the sh script overcloud_ceph_deploy.sh is executed.
2.
3.

Actual results: ceph fails to deploy with error above


Expected results: ceph deploys successfully


Additional info:

Comment 4 David Rosenfeld 2022-07-11 13:31:38 UTC
During phase 3 execution of RHOS-17.0-RHEL-9-20220708.n.1 ceph deployed successfully from satellite.

Also this is from logs. The previous command that had two slashes now only has one:

undercloud1702-0.ctlplane.redhat.local:8787/default_organization-ceph4_6_containers-rhceph:5-170

Comment 10 errata-xmlrpc 2022-09-21 12:22:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Release of components for Red Hat OpenStack Platform 17.0 (Wallaby)), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2022:6543