Bug 209869 - TypeError: expected string or buffer
Summary: TypeError: expected string or buffer
Status: CLOSED DUPLICATE of bug 209889
Alias: None
Product: Fedora
Classification: Fedora
Component: rpmlint   
(Show other bugs)
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ville Skyttä
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-07 05:03 UTC by Ralf Corsepius
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-09 17:32:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ralf Corsepius 2006-10-07 05:03:05 UTC
Description of problem:

# rpmlint -a
[.. very long report ..]
Traceback (most recent call last):
  File "/usr/share/rpmlint/rpmlint.py", line 268, in ?
    main()
  File "/usr/share/rpmlint/rpmlint.py", line 124, in main
    runChecks(pkg)
  File "/usr/share/rpmlint/rpmlint.py", line 149, in runChecks
    c.check(pkg)
  File "/usr/share/rpmlint/BinariesCheck.py", line 140, in check
    res=srcname_regex.search(pkg[rpm.RPMTAG_SOURCERPM])
TypeError: expected string or buffer

Version-Release number of selected component (if applicable):
rpmlint-0.78-1.fc5

How reproducible:
ATM, I can reproduce it deterministically on two machines, but I don't have any
idea if this related to a particular installed rpm, or a general bug in rpmlint
or python.

Comment 1 Ville Skyttä 2006-10-09 17:32:10 UTC
The backtrace the same as in bug 209889 - I'm pretty sure that this is the 
same issue.  Marking as a dupe of bug 209889 because it has a reproducer, more 
info there shortly.

*** This bug has been marked as a duplicate of 209889 ***


Note You need to log in before you can comment on or make changes to this bug.