Bug 209977 - nfs v3 data cache inconsistency
nfs v3 data cache inconsistency
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Steve Dickson
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-09 02:23 EDT by Piete Brooks
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-12 02:15:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Piete Brooks 2006-10-09 02:23:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1) Gecko/20061003 Firefox/2.0

Description of problem:
If data is written to an NFS file on another machine, this machine sees the change in the length, but not in the data

Version-Release number of selected component (if applicable):
kernel-2.6.18-1.2747.fc6

How reproducible:
Always


Steps to Reproduce:
1.create a file on thois machine and checkthe contents
2.Overwrite the file on another machine
3.Look at the file on this machine

Actual Results:
% echo CBA > tmp/n; od -c tmp/n; ssh -n -x greta echo X \> tmp/n; od -c tmp/n
0000000   C   B   A  \n
0000004
0000000   C   B
0000002
% 

Expected Results:
Should have seen "X\n"

Additional info:
Comment 1 Dave Jones 2006-10-10 00:14:55 EDT
possible dupe of #209420
Comment 2 Piete Brooks 2006-10-10 02:09:35 EDT
I agree -- it looks just like #209420 -- sorry I didn't spot it when scanning
before reporting the problem :-(

The patch seems scaringly simple (i.e. allow it to sleep!)
Comment 3 Piete Brooks 2006-10-12 02:01:00 EDT
Fixed in 2.6.18-1.2759.fc6, so feel free to close the ticket. Thanks.

teith:~: echo CBA>tmp/n;od -c tmp/n;ssh -n -x greta echo X\>tmp/n;od -c tmp/n
0000000   C   B   A  \n
0000004
0000000   X  \n
0000002
teith:~: uname -a
Linux teith.cl.cam.ac.uk 2.6.18-1.2759.fc6 #1 SMP Tue Oct 10 17:34:23 EDT 2006
x86_64 x86_64 x86_64 GNU/Linux
teith:~: 
Comment 4 Dave Jones 2006-10-12 02:15:34 EDT
Cool, thanks for testing.

Note You need to log in before you can comment on or make changes to this bug.