Bug 2100230 - Bluetooth AX200 broken after version 20220610-135.fc36 of linux-firmware
Summary: Bluetooth AX200 broken after version 20220610-135.fc36 of linux-firmware
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: linux-firmware
Version: 36
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: David Woodhouse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-06-22 19:09 UTC by CFW
Modified: 2022-07-28 19:59 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-07-28 19:59:14 UTC
Type: Bug


Attachments (Terms of Use)
journalctl and lsub output (14.42 KB, text/plain)
2022-06-22 19:09 UTC, CFW
no flags Details

Description CFW 2022-06-22 19:09:31 UTC
Created attachment 1891982 [details]
journalctl and lsub output

Description of problem:
Since upgrade to 20220610-135.fc36 the bluetooth part of my Intel AX200 PCIE card is no more working.

Version-Release number of selected component:20220610-135.fc36


How reproducible:
With  WIFI+BT TP-LINK TX3000 card (2 card tested, whatever USB header on motherboard is used)


Steps to Reproduce:
1.dnf upgrade to get kernel : 5.18.5-200.fc36.x86_64 #1 SMP PREEMPT_DYNAMIC Thu Jun 16 14:51:11 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux and linux-firmware in question
2.reboot
3.BT no more working

Actual results:
BT not working

Expected results:
BT  working


Additional info:
In attachment the results of : 
journalctl --dmesg --boot=-0 --grep blue
lsusb -v -d 8087:0029 with the following message: "Bus 001 Device 007: ID 8087:0029 Intel Corp. AX200 Bluetooth Couldn't open device, some information will be missing"

Downgrade of linux-firmware.noarch and linux-firmware-whence.noarch makes the BT working again (with release 20220310-130.fc36)

Comment 1 Peter Robinson 2022-07-28 12:42:50 UTC
Is it fixed now with the latest linuux-firware, or with a newer kernel?

Comment 2 CFW 2022-07-28 19:03:22 UTC
Hi.

It's working with linux-firmware-20220708-136.fc36.

Thanks


Note You need to log in before you can comment on or make changes to this bug.