Bug 210029 - autofs wakes up every second... even when not in use
autofs wakes up every second... even when not in use
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ian Kent
Brock Organ
:
Depends On:
Blocks: wakeup
  Show dependency treegraph
 
Reported: 2006-10-09 12:25 EDT by Arjan van de Ven
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-21 21:49:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Arjan van de Ven 2006-10-09 12:25:15 EDT
Description of problem:


automount daemon is waking the system up every second, even when it's not in use
at all! This is eating unneeded power / battery

also, the following comment is *wrong* and actually increases power usage for no
good reason:
        /* We often start several automounters at the same time.  Add some
           randomness so we don't all expire at the same time. */

please make all timers fire at the same time instead!
Comment 1 Ian Kent 2006-10-09 13:22:52 EDT
(In reply to comment #0)
> Description of problem:
> 
> 
> automount daemon is waking the system up every second, even when it's not in use
> at all! This is eating unneeded power / battery

Some supporting evidence would be useful and is actually really needed.

> 
> also, the following comment is *wrong* and actually increases power usage for no
> good reason:
>         /* We often start several automounters at the same time.  Add some
>            randomness so we don't all expire at the same time. */
> 
> please make all timers fire at the same time instead!

Why?
Some justification would be useful here as well since your view
of what's actually happening here may not be what you think.

Ian
Comment 2 Arjan van de Ven 2006-10-09 14:14:15 EDT
curiously after a few reboots a strace no longer shows this behavior. WEIRD
Comment 3 Ian Kent 2006-10-09 14:29:40 EDT
(In reply to comment #2)
> curiously after a few reboots a strace no longer shows this behavior. WEIRD
> 

Perhaps the real culprit is behaving.
Changing DEFAULT_LOGGING="none" to DEFAULT_LOGGING="debug" and telling
syslog to send daemon.debug to somewhere useful will log the pid of
processes requesting mounts and show when autofs expire events actually
occur.

Ian
Comment 4 Jeffrey Moyer 2006-12-19 15:43:36 EST
Is this bug supposed to be in NEEDINFO?  Arjan, how were you determining that
autofs wakes up?  With a simple strace of the automount pid?  Is that going to
be accurate given autofs is threaded?
Comment 5 Ian Kent 2007-01-21 21:49:47 EST
(In reply to comment #4)
> Is this bug supposed to be in NEEDINFO?  Arjan, how were you determining that
> autofs wakes up?  With a simple strace of the automount pid?  Is that going to
> be accurate given autofs is threaded?

No response.
Closing as NOTABUG.
Arjan, please re-open if this is still an issue
with the latest autofs and mlocate packages.

Ian
Comment 6 William Lovaton 2007-08-26 17:02:05 EDT
powertop shows constantly 1 wake up every second for automount.  Is there
something we can do to solve this?  I'm using latest Rawhide as of today.
Comment 7 Jeffrey Moyer 2007-08-27 10:10:20 EDT
(In reply to comment #6)
> powertop shows constantly 1 wake up every second for automount.  Is there
> something we can do to solve this?  I'm using latest Rawhide as of today.

Do you use autofs?  If not, the simple answer is don't start it.

If you are using autofs, then there is one potential optimization.  We could
disable the alarm when no file systems are mounted.
Comment 8 William Lovaton 2007-08-27 22:35:47 EDT
You are right, I thought I needed it but I don't so I disabled it.  Curiously
enough the wakeups went down from 20 to 16 per second even when powertop showed
that automount was causing just one wps.

Cheers.

Note You need to log in before you can comment on or make changes to this bug.