This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 210092 - Configuring bootargs causes pygrub to fail
Configuring bootargs causes pygrub to fail
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Juan Quintela
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-09 18:39 EDT by Bertho
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version: xen-3.0.3-8.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-21 11:42:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bertho 2006-10-09 18:39:42 EDT
Description of problem:
Entering the configuration option "bootargs" in a domain configuration file in
combination with 'bootloader="/usr/bin/pygrub"' causes 'xm create mybox0' to
fail with the message: "Error: append() takes exactly one argument (2 given)".
It surely can be that I am doing something wrong here, but I can't see what...


Version-Release number of selected component (if applicable):
- Fedora Core 6 test3 (development version 2006-Oct-08)
- xen-3.0.2-44
- Clean install and a clean guest created with xenguest-install script

How reproducible:
[root@xen /etc/xen]# xm create -c mybox0
Using config file "mybox0".
Going to boot Fedora Core (2.6.18-1.2747.fc6xen)
  kernel: /boot/vmlinuz-2.6.18-1.2747.fc6xen
  initrd: /boot/initrd-2.6.18-1.2747.fc6xen.img
Error: append() takes exactly one argument (2 given)

Steps to Reproduce:
1. Put in config file /etc/xen/mybox0:
     * bootloader="/usr/bin/pygrub"
     * bootargs="-q"
2. start the domain
  
Actual results:
Domain not started

Expected results:
domain started

Additional info:
Changing the bootargs argument to [ '-q' ] does not help and fails with "Error:
'list' object has no attribute 'read'". This makes sense because the source file
 /usr/lib/python2.4/site-packages/xen/xm/create.py at line 128 requires a simple
string value like the bootloader option.
Comment 1 Stephen Tweedie 2006-10-10 08:55:18 EDT
Fixed upstream in xen-unstable cset 11636:

http://xenbits.xensource.com/xen-unstable.hg?cs=e759cc598822

We'll be pulling in xen-3.0.3 final when that comes out (expected soon), and
that contains this fix.
Comment 3 Daniel Berrange 2007-03-21 11:42:10 EDT
The current update in FC6 is 3.0.3-8.fc6 which has the fix now, so closing this
ticket.

Note You need to log in before you can comment on or make changes to this bug.