Bug 210110 - running ldd on ar-archives
Summary: running ldd on ar-archives
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rpmlint   
(Show other bugs)
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ville Skyttä
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-10 02:25 UTC by Ralf Corsepius
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 0.78-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-15 14:04:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ralf Corsepius 2006-10-10 02:25:00 UTC
Description of problem:

rpmlint seems to be running ldd on ar-archives:

# rpmlint openssl-devel
..
W: openssl-devel ldd-failed /usr/lib/libcrypto.a
W: openssl-devel ldd-failed /usr/lib/libssl.a


To me, this behavior doesn't make any sense.

Version-Release number of selected component (if applicable):

rpmlint-0.78-1.fc5

Comment 1 Ville Skyttä 2006-10-13 18:44:03 UTC
Indeed.  Fixed upstream, thanks for the heads up: 
http://rpmlint.zarb.org/cgi-bin/trac.cgi/changeset/1289

Comment 2 Ville Skyttä 2006-10-15 14:04:22 UTC
Fixed in 0.78-2.fc*


Note You need to log in before you can comment on or make changes to this bug.