Bug 210114 - giFT: looks for plugins in /usr/lib/giFT instead of /usr/lib64/giFT
giFT: looks for plugins in /usr/lib/giFT instead of /usr/lib64/giFT
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gift (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-09 23:37 EDT by Chad Calkins
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-10 08:45:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
respect/use $bindir, $datadir, $includedir, $libdir (1.58 KB, patch)
2006-10-10 08:23 EDT, Rex Dieter
no flags Details | Diff

  None (edit)
Description Chad Calkins 2006-10-09 23:37:44 EDT
Description of problem:
giFT looks for plugins in /usr/lib/giFT instead of /usr/lib64/giFT



Version-Release number of selected component (if applicable):
gift 0.11.8.1

How reproducible:
Very

Steps to Reproduce:
1. Install gift.x86_64
   Install gift-openft.x86_64
2. At prompt type: giftd -V

Actual results:
PLUGIN_DIR=/usr/lib/giFT

Expected results:
PLUGIN_DIR=/usr/lib64/giFT

Additional info:
PLUGIN_DIR is set at build time for gift.  Moving the plugins to /usr/lib/giFT 
works, but as the plugins are x86_64 it seems that they should be in lib64
Comment 1 Rex Dieter 2006-10-10 08:20:43 EDT
Thanks for the report, I'll take a look.
Comment 2 Rex Dieter 2006-10-10 08:21:39 EDT
Arg, looks like upstream devs hard-code ${prefix}/lib/giFT alright (as well as a
few other things).  Looks easy enough to fix.
Comment 3 Rex Dieter 2006-10-10 08:23:23 EDT
Created attachment 138130 [details]
respect/use $bindir, $datadir, $includedir, $libdir
Comment 4 Rex Dieter 2006-10-10 08:45:21 EDT
Reported upstream, fixed builds queued:

* Tue Oct 10 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.11.8.1-6
- patch to respect %_bindir,%_datadir,%_includedir,%_libdir (#210114)

Note You need to log in before you can comment on or make changes to this bug.