Bug 210121 - Printing does not produce correct post-script
Printing does not produce correct post-script
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: geda-gschem (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chitlesh GOORAH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-10 02:41 EDT by Ralph Loader
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-13 09:15:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralph Loader 2006-10-10 02:41:17 EDT
Description of problem:

Printing from gschem produces invalid postscript due to a missing file
/usr/share/gEDA/prolog.ps

Version-Release number of selected component (if applicable):

geda-gschem-20060906-2.fc6

How reproducible:

Every time.

Steps to Reproduce:
1.  Print a schematic to file.
2.  Open in a postscipt viewer e.g., evince.
3.
  
Actual results:

The gschem log gets:

Unable to open the prolog file `/usr/share/gEDA/prolog.ps' for reading in
f_print_header()
Giving up on printing

The postscript interpreter chokes on the output file.

Expected results:

Postscript output should be correct postscript.

Additional info:

Copying the prolog.ps file from gschem cvs into /usr/share/gEDA/prolog.ps fixes
the problem.
Comment 1 Chitlesh GOORAH 2006-10-11 03:56:30 EDT
Thanks for notifying it to me.

/usr/share/gEDA/prolog.ps comes with libgeda-doc. Indeed this is a packaging
error. could you install libgeda-doc and repeat your procedure (of course
deleting the one you place by hand) to see whether that fixes it or not ?

chitlesh(~)[0]$rpm -qf /usr/share/gEDA/prolog.ps
libgeda-doc-20060906-1.fc5

chitlesh(~)[0]$rpm -ql libgeda-doc-20060906-1.fc5
/usr/share/doc/libgeda-doc-20060906
/usr/share/doc/libgeda-doc-20060906/libgeda-main.txt
/usr/share/doc/libgeda-doc-20060906/logo.png
/usr/share/doc/libgeda-doc-20060906/texinfo.tex
/usr/share/doc/libgeda-doc-20060906/what-is-geda.html
/usr/share/doc/libgeda-doc-20060906/what-is-libgeda.html
/usr/share/gEDA/prolog.ps
Comment 2 Ralph Loader 2006-10-12 00:17:55 EDT
Yes, installing libgeda-doc fixes the problem.

Thanks.
Comment 3 Chitlesh GOORAH 2006-10-13 09:15:03 EDT
I've rebuilt libgeda appropriately

Note You need to log in before you can comment on or make changes to this bug.