Bug 210124 - libtorrent-devel appears to be missing headers
libtorrent-devel appears to be missing headers
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libtorrent (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Chabot
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-10 03:23 EDT by Benno Rice
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-10 05:12:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benno Rice 2006-10-10 03:23:03 EDT
Description of problem:
libtorrent-devel doesn't appear to include the appropriate headers for libtorrent applications to 
compile, for example libtorrent/session.hpp

Version-Release number of selected component (if applicable):
0.10.2 2.fc5

How reproducible:
Try to build an application requiring libtorrent, eg btg (http://btg.berlios.de/)
  
Actual results:
Build fails due to missing header.

Expected results:
Build succeeds.
Comment 1 Chris Chabot 2006-10-10 05:12:10 EDT
Seems the "session.hpp is missing" is the error btg gives me, however:

# tar xvfz Desktop/libtorrent-0.10.3.tar.gz
# cd libtorrent-0.10.3
# find -name "*.hpp"
< nothing>
# find -name "session*"
<nothing>

Its not a part of libtorrent, error seems to be in btg, and not in the packaging
of libtorrent; All header files from libtorrent are included in the -devel package:

# rpm -ql libtorrent-devel
/usr/include/torrent
/usr/include/torrent/bitfield.h
/usr/include/torrent/block.h
/usr/include/torrent/block_list.h
/usr/include/torrent/block_transfer.h
/usr/include/torrent/chunk_manager.h
/usr/include/torrent/common.h
/usr/include/torrent/connection_manager.h
/usr/include/torrent/download.h
/usr/include/torrent/event.h
/usr/include/torrent/exceptions.h
/usr/include/torrent/file.h
/usr/include/torrent/file_list.h
/usr/include/torrent/http.h
/usr/include/torrent/object.h
/usr/include/torrent/object_stream.h
/usr/include/torrent/path.h
/usr/include/torrent/peer.h
/usr/include/torrent/peer_info.h
/usr/include/torrent/peer_list.h
/usr/include/torrent/piece.h
/usr/include/torrent/poll.h
/usr/include/torrent/poll_epoll.h
/usr/include/torrent/poll_kqueue.h
/usr/include/torrent/poll_select.h
/usr/include/torrent/rate.h
/usr/include/torrent/resume.h
/usr/include/torrent/torrent.h
/usr/include/torrent/tracker.h
/usr/include/torrent/tracker_list.h
/usr/include/torrent/transfer_list.h
/usr/lib/libtorrent.so
/usr/lib/pkgconfig/libtorrent.pc

Comment 2 Benno Rice 2006-10-10 07:00:32 EDT
Ah, right.  It seems that this is not the Rasterbar libtorrent.  It'd be nice if people didn't choose conflicting 
names. =)

Note You need to log in before you can comment on or make changes to this bug.