Bug 210125 - F9 Hanja conversion is a little slow
F9 Hanja conversion is a little slow
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: scim-hangul (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hu Zheng
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-10 04:28 EDT by Warren Togami
Modified: 2008-01-02 23:41 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-02 23:41:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2006-10-10 04:28:21 EDT
When you try to convert Hangul to Hanja (Chinese characters) using the F9
button, it has a noticable delay before the character selection menu pops up. 
This delay happens every time you use it, not just the first attempt.

This is annoying to regular users of Hanja.

scim-1.4.4-34.fc6
scim-bridge-0.4.5-2.fc6
scim-hangul-0.2.2-7.fc6
gtk2-2.10.4-2.fc6
Comment 1 Warren Togami 2006-10-17 09:59:42 EDT
djoo and krisna suspected that this problem might be limited to scim-hangul when
using scim-bridge immodule.  Testing indicates this is the case.  So maybe
scim-bridge is the problem.  Any thoughts Dairiki?
Comment 2 Ryo Dairiki 2006-10-17 11:11:24 EDT
I don't know.
It seems it's okay for me; I cannot see any delaying before showing the popups.
Do you have any good example for this problem?

Btw, how long it dealys? A second or longer?
Comment 3 Jens Petersen 2007-12-18 02:18:25 EST
Can you reproduce this, Hu Zheng?
Comment 4 Hu Zheng 2007-12-24 22:13:03 EST
I have tested it in Fedora 8, after press F9, the selection menu pops up very
quickly.
Can you still reproduce it in Fedora 8?
Comment 5 Warren Togami 2007-12-24 23:00:25 EST
I just tested this on my F8 laptop, and it seems quick.  I don't know if this is
because I have a much faster laptop than during 2006.  How is this on a slower
computer?
Comment 6 Jens Petersen 2008-01-02 23:41:54 EST
Let's close this for now - please reopen if you should still see a problem.
(Perhaps it was fixed indirectly somehow in scim-bridge say.)

Note You need to log in before you can comment on or make changes to this bug.