Bug 210126 - Cannot connect to exchange Global Address List
Cannot connect to exchange Global Address List
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
: 166717 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-10 04:59 EDT by Ian Dall
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-27 14:57:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to allow configure to properly find ldap_ntlm_bind (1.05 KB, patch)
2006-10-10 04:59 EDT, Ian Dall
no flags Details | Diff
Patch to evolution-data-server.spec to enable static ldap (1.10 KB, patch)
2006-10-10 05:02 EDT, Ian Dall
no flags Details | Diff

  None (edit)
Description Ian Dall 2006-10-10 04:59:46 EDT
Description of problem:
When attempting to use "Contacts" in the Exchange Global Address List
an error message pops up indicating unable to open address book.

Version-Release number of selected component (if applicable):

1.6.3-1.fc5.2, but also seen in 1.8.0-2.fc6 from development.

How reproducible:

Always, but may depend on configuration of the exchange server.

Steps to Reproduce:
1.Create an exchange account
2.Select secure authentication
3.Select the exchange Global Address List.
  
Actual results:

An eroor pops up indicating unable to open address book.

Expected results:

Address book opened and able to find contacts in address book.

Additional info:

Even though this seems like a problem in evolution-connector it is not. It is
evolution its self which connects to the global address list, but it does it
using a library from evolution-data-server. When building evolution-data-derver
from the SRPM, the following is output is logged:

 checking for ldap_ntlm_bind... no

and later:

        evolution-data-server has been configured as follows:
        Mail Directory:   /var/spool/mail, writable by group mail
        LDAP support:     /usr (dynamic)
        NNTP support:     yes
        Kerberos 4/5:     no/yes (MIT)
        SSL support:      yes (Mozilla NSS)
        SMIME support:    yes (Mozilla NSS)
        IPv6 support:     yes
        Exchange support: no
        Dot Locking:      no
        File Locking:     fcntl
        Large files:      yes
        Gtk Doc:          no


configure: WARNING:
No NTLM support in OpenLDAP; Plaintext password authentication will be
used when connecting to the Exchange Global Catalog server. Consider
installing the evo-openldap package, or building OpenLDAP with the
patch in servers/exchange/docs/openldap-ntlm.diff


I have the correct library installed from openldap-devel-2.3.19-4, but it is not
being used. To fix this, static_ldap needs to be defined, but this is not
sufficient by its self, because configuration still fails to find
ldap_ntlm_bind. The attached patches fix the problem. It is possible that some
of this would not be necessary if openldap-devel supplied a .la file to specify
dependancies.
Comment 1 Ian Dall 2006-10-10 04:59:46 EDT
Created attachment 138124 [details]
Patch to allow configure to properly find ldap_ntlm_bind
Comment 2 Ian Dall 2006-10-10 05:02:42 EDT
Created attachment 138125 [details]
Patch to evolution-data-server.spec to enable static ldap

Does always enabling static ldap cause any problems for non-exchange users?
Comment 3 Matthew Barnes 2006-11-10 21:01:36 EST
*** Bug 166717 has been marked as a duplicate of this bug. ***
Comment 4 Henry Leung 2007-03-27 01:45:31 EDT
This problem also happens in Fedora Core 6. I already applied latest updates 
to the whole system. The problem still not solved. Does anyone have idea on it?
Comment 5 Matthew Barnes 2007-03-27 14:57:48 EDT
Ian, thanks for the patches.  It turns out that evolution-connector also uses
static LDAP and has NTLM support working.  So I took a look at how that package
does it and pulled the necessary bits from evolution-connector.spec.

It seems to be working with no modifications to acinclude.m4, according to the
configure output [1].  Let me know if this doesn't solve your problem and I'll
reopen this bug and take second look at your patches.

evolution-data-server-2.10.0-4.fc7


[1] The configuration output now gives...

    checking for ldap_ntlm_bind... yes

    ...

    evolution-data-server has been configured as follows:
    Mail Directory:   /var/spool/mail, writable by group mail
    LDAP support:     /usr/lib/evolution-openldap (static)
    NNTP support:     yes
    Kerberos 4/5:     no/yes (MIT)
    Gnome Keyring:    no/
    SSL support:      yes (Mozilla NSS)
    SMIME support:    yes (Mozilla NSS)
    IPv6 support:     yes
    Berkeley DB:      dynamically linked
    Exchange support: yes
    Dot Locking:      no
    File Locking:     fcntl
    Large files:      yes
    Gtk Doc:          no

Note You need to log in before you can comment on or make changes to this bug.