This service will be undergoing non-disruptive maintenance at 07:20 UTC, 2018-12-14. It is expected to last approximately 30 minutes
Bug 210151 - Totem-mozilla plugin crashes firefox
Summary: Totem-mozilla plugin crashes firefox
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact:
URL:
Whiteboard:
Keywords: Desktop
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-10 14:23 UTC by Michal Babej
Modified: 2013-07-31 23:10 UTC (History)
5 users (show)

Fixed In Version: 2.18.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-05 09:49:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
GDB backtrace of the crash (8.48 KB, text/plain)
2006-10-10 14:23 UTC, Michal Babej
no flags Details
Frysk output with every thread's bt on crash (17.56 KB, text/plain)
2006-10-10 15:30 UTC, Michal Babej
no flags Details
GDB backtrace in Mayhem 20061024.0 (7.53 KB, text/plain)
2006-10-25 12:53 UTC, Michal Babej
no flags Details

Description Michal Babej 2006-10-10 14:23:05 UTC
Description of problem:


Version-Release number of selected component (if applicable):
totem-mozplugin-2.16.1-1.fc6
firefox-1.5.0.7-6.fc6

How reproducible:
always

Steps to Reproduce:
0. i have firefox set up so that it opens everything in a new tab instead of a
window.
1. open firefox. go to a page with mpg videos (i used
http://digital-desert.com/mpg-videos/)
2. open a web-page link from that page in a new tab (i opened one of those on
the right side)
3. wait until it loads, close the new tab.
4. now click on one of video-files link. a new tab appears, with a blank
black-coloured page and an error message from totem that it cannot play the file
(probably no codec installed)
5. close the tab with video.
6. click right button on the same video-file link, select Save As.
7. firefox receives SIGSEGV
  
Actual results:
SIGSEGV

Additional info:
gdb backtrace in attachment.

Comment 1 Michal Babej 2006-10-10 14:23:06 UTC
Created attachment 138137 [details]
GDB backtrace of the crash

Comment 2 Michal Babej 2006-10-10 15:30:40 UTC
Created attachment 138151 [details]
Frysk output with every thread's bt on crash

Comment 3 Michal Babej 2006-10-25 12:52:19 UTC
Hmm, also present in Mayhem (though i tested it without fluendo codecs
installed) tree 20061024.0

Comment 4 Michal Babej 2006-10-25 12:53:35 UTC
Created attachment 139343 [details]
GDB backtrace in Mayhem 20061024.0

Comment 5 Bastien Nocera 2006-10-27 09:25:58 UTC
There's not one bit of Totem related sources in the backtrace, and it looks like
the browser is trying to show you a file chooser:

#18 0x0030cfb8 in nsFilePicker::Show (this=0xa7dcea8, aReturn=0xbfae1330)
    at nsFilePicker.cpp:567

Not a Totem bug.

Comment 7 Sitsofe Wheeler 2007-03-11 09:03:23 UTC
This problem was eventually worked around by changing the totem plugin:
http://bugzilla.gnome.org/show_bug.cgi?id=415389

Comment 8 Bastien Nocera 2007-04-05 09:49:08 UTC
If that's the same bug, then it should be fixed in Totem 2.18.0 (2.18.1 is the
current rawhide build).


Note You need to log in before you can comment on or make changes to this bug.