This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 210175 - md: set_bitmap_file ioctl is not 32 bit compatible
md: set_bitmap_file ioctl is not 32 bit compatible
Status: CLOSED DUPLICATE of bug 219338
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-10 12:24 EDT by Paul Clements
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-30 10:39:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch (400 bytes, patch)
2006-10-10 12:24 EDT, Paul Clements
no flags Details | Diff

  None (edit)
Description Paul Clements 2006-10-10 12:24:59 EDT
Description of problem:

The SET_BITMAP_FILE ioctl does not have a 32-bit ioctl compatibility entry. This
means that 32-bit mdadm will not work on 64-bit platforms (x86_64, ppc64, etc.).

Version-Release number of selected component (if applicable):

kernel 2.6.17-1.2519.4.21.el5

Patch attached.
Comment 1 Paul Clements 2006-10-10 12:24:59 EDT
Created attachment 138157 [details]
patch
Comment 2 Doug Ledford 2007-11-30 10:39:32 EST

*** This bug has been marked as a duplicate of 219338 ***

Note You need to log in before you can comment on or make changes to this bug.