Bug 210190 - crashed hitting back on grub advanced options
Summary: crashed hitting back on grub advanced options
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-10 17:55 UTC by Steven Rostedt
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-10 19:40:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug dump from anaconda (92.77 KB, text/plain)
2006-10-10 17:55 UTC, Steven Rostedt
no flags Details

Description Steven Rostedt 2006-10-10 17:55:23 UTC
Description of problem:
On install, I made it all the way to the screen just before installing the 
packages.  Then I wanted to change the grub options (which I had set to
not install grub, since I already had grub installed on the MBR). I hit the
advanced options and set it to install on one of the partitions instead. Then
I hit the back button, and got the anaconda crash. 

Version-Release number of selected component (if applicable):
anaconda-11.1.0.109-1.x86_64.rpm

How reproducible:
Very

Steps to Reproduce:
(what's not listed is just defaults)
1. booted pxe
2. Started http install
3. custom layout
4. Added LV to existing VG *
5. used existing normal partition for /boot (and format) *
6. selected not to install grub
7. select all defaults upto where it will start the package installations
8. hit the back button until you are at the grub screen again
9. select grub
10. select advanced grub options
11. hit next
12. select to install grub on a partition (not MRB)
13. hit back
14. BANG!

* these steps are required for me, but probably isn't the reason for the bug.

  
Actual results:
Anaconda crashes.

Expected results:
Anaconda doesn't crash

Additional info:

Comment 1 Steven Rostedt 2006-10-10 17:55:25 UTC
Created attachment 138173 [details]
bug dump from anaconda

Comment 2 Chris Lumens 2006-10-10 19:40:12 UTC
Fixed the traceback, but there's still some issues with the screen forgetting
what you previously selected.


Note You need to log in before you can comment on or make changes to this bug.