Bug 21025 - forgets password
forgets password
Status: CLOSED WORKSFORME
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.8
i386 Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-17 13:11 EST by dkaplan
Modified: 2007-04-18 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-12 07:43:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dkaplan 2000-11-17 13:11:28 EST
Hi,

Bugzilla seems to forget that I logged in every time.  One of the cookies
it sends, 
Bugzilla_password has an expiration date in the past - 1969.  I imagine
that is why.

David
Comment 1 David Lawrence 2001-03-12 10:43:34 EST
Normally if you receive a cookie that is set to expire in January 1969, Bugzilla
is sending it because you logged out or authentification failed due to incorrect
password or email address. By setting this date to 1969, your browser will then
delete the cookie from your cookies file since it is already expired. When you
do successfully log in then several cookies are set by Bugzilla that have an
expiration date well into the future, something like 2029. The bugzilla database
actually does some house keeping by cleaning out cookies that have not been used
for 30 days so in practice youy would never have the same cookie til 2029 anyway. 

I cannot recreate the problem as you have stated.Please reopen this bug if you
have further information.

Note You need to log in before you can comment on or make changes to this bug.