Bug 210252 - Bluetooth Manager useless
Bluetooth Manager useless
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-bluetooth (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-10 19:38 EDT by David Tenser
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-27 04:28:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Tenser 2006-10-10 19:38:38 EDT
Description of problem:
The Bluetooth Manager installed by default in FC6Pre (DVD i386) is useless. It
is capable of detecting my bluetooth device, but clicking on a found device does
nothing. Nor does double-clicking or right-clicking on it. If you select the
device and then choose Edit > Properties, nothing happens. The Help menu just
contains a useless About item. No Help there at all.

Really, what is this Bluetooth Manager meant to manage? There is not even an
option to pair devices. How is the bluetooth support in Fedora Core supposed to
actually perform any sort of communication with other devices other than listing a 

Version-Release number of selected component (if applicable):
Bluetooth Device Manager 0.7.0
Comment 1 David Tenser 2006-10-10 19:43:24 EDT
I must have made a mistake when editing the summary. The last sentence was
supposed to read: "How is the bluetooth support in Fedora Core supposed to
actually perform any sort of communication with other devices other than listing
an icon for my bluetooth device?"
Comment 2 David Woodhouse 2006-10-11 02:23:02 EDT
This isn't a bluez-utils bug -- bluez-utils is just the low-level support for
such things, and is working fine (at least, the bluez-utils-3.7 package which
_ought_ to have been in FC6 but which is going out as an update immediately
after the actual release is working fine).

Yes, the point-and-drool stuff is somewhat lacking. The bluez-gnome package will
in time remedy that, but in the meantime you have to do things manually.

What is it that you want to do?
Comment 3 David Tenser 2006-10-11 04:52:41 EDT
(In reply to comment #2)
> What is it that you want to do?

Most important of all, I would like the Bluetooth Manager UI to not be broken.
The fact that nothing happens when you select Edit > Properties on a device is
bad from a usability point of view. The fact that there is no help available
makes the experience even more frustrating. You simply cannot do anything with
the manager, other than scanning for devices and removing them from the window
again. Also, the UI doesn't give you any visual feedback when selecting File >
Scan to give you a clue that it's actually scanning.

Other things that would be nice to do is: 

1. Query a list of supported bt services on a particular device.
2. Pair a device with the computer and set up access rules.
3. Mass send/receive of files using a shared bluetooth folder (although that may
be more of a Nautilus feature).

Comment 4 David Woodhouse 2006-10-11 05:14:11 EDT
These are things that bluez-gnome should address, in time. We'll probably end up
dropping gnome-bluetooth altogether.
Comment 5 David Woodhouse 2006-10-11 05:21:25 EDT
btw:

1. sdptool browse <bdaddr>
2. pairing will happen when you try to make a connection which requires it. Make
sure you've got the current packages from http://david.woodhou.se/bluez/
installed, not the old versions which are in FC6 release.
3. cd /whichever/directory ; gnome-obex-send --dest <bdaddr> *
Comment 6 David Tenser 2006-10-11 05:28:43 EDT
Those are excellent tips for a geek like me. :) However, this bug was reported
based on what's available by default in a standard FC6 release. Your last posts
raises the question why FC6 has "old versions" of important packages installed
by default?

If the solution to common bluetooth use cases is to manually install unsupported
third party packages (involving the use of scary terminals), then my suggestion
is to remove gnome-bluetooth altogether and wait until the solution actually
work for regular people.
Comment 7 David Woodhouse 2006-10-11 05:51:14 EDT
FC6 has old and known broken (in some ways) versions because when I wanted to
update them two weeks ago I was told that I wasn't allowed to.

The packages in FC6 should probably work for what you're trying to do, but
haven't been tested as well as the new packages and I'm not interested if they
_don't_ work unless you can also reproduce the problem with the new packages.

gnome-bluetooth does currently provide working support for _receiving_ files,
and (from the command line) for sending files. It's just
nautilus-sendto-bluetooth which is broken.

I'd probably agree that gnome-bluetooth-manager might as well be removed, but I
try not to get involved with the point-and-drool stuff so I don't own the
package in question.
Comment 8 David Tenser 2006-10-11 07:03:47 EDT
The fact that Fedora/Redhat accepts having old and known broken software in the
default installation and permits updating of them without good reasons is a bit
discouraging. Is it unreasonable to ask that the owner of the package in
question steps up and explains the situation? Is no one besides me actually
trying to use the bluetooth software provided in Fedora?

Thanks David for responding even though you don't own the gnome-bluetooth
package. I understand your point of view; you don't particularly like GUI front
ends and you're not allowed to fix a broken package. However, I must point out
that a working front end is just as important as a working back end from a
user's point of view. Few users would accept using a terminal window to send a
file to the phone in e.g. Windows XP.

Also, the bits provided in Fedora are the ones that should be focused on. If a
reported bug is not interesting unless it also occurs in a more recent
third-party build, then that sends a message to the end users that what Fedora
itself provides is not reliable.

Let this bug report be a reminder that some people actually try to use the
software that comes with a default installation of an OS. :)
Comment 9 David Tenser 2006-10-11 07:05:31 EDT
s/permits/prohibits/
Comment 10 Harald Hoyer 2006-10-11 07:53:29 EDT
well, it was a little bit late in the game (release plan) for a new version..
will make an test-erratum asap
Comment 11 David Woodhouse 2006-10-11 09:23:14 EDT
I am the maintainer of the packages in question (bluez-libs, bluez-utils). The
packages in the repository I pointed you at are the packages which I want in FC6
final and which I'll release as errata. For further background on that see
https://www.redhat.com/archives/fedora-devel-list/2006-September/msg00832.html

It's not that I don't like the GUI front end -- I've largely just ignored it;
mostly because, as you observe, it doesn't really do much. I use Bluetooth
frequently in Fedora -- with dialup, OBEX receive (and occasionally send),
Bluetooth mouse and Bluetooth networking (PAN). It works fine.

Harald, if you have some time for this it would be really good to combine the
functionality which is in gnome-bluetooth into the new bluez-gnome package.
Comment 12 Matthew Miller 2007-04-06 12:09:19 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 13 Ondrej Vasik 2007-06-27 04:28:41 EDT
Gnome-bluetooth-manager was removed from the latest upstream (and Fedora)
versions of gnome-bluetooth package. Was removed from current FC-6 version too.
Closing WONTFIX

Note You need to log in before you can comment on or make changes to this bug.