Bug 210253 - Nautilus Send to > Bluetooth doesn't work
Nautilus Send to > Bluetooth doesn't work
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nautilus-sendto (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-10 19:59 EDT by David Tenser
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-02 01:24:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 361520 None None None Never

  None (edit)
Description David Tenser 2006-10-10 19:59:26 EDT
Description of problem:
In FC6Pre (all latest updates installed 2006-10-11), sending files via Bluetooth
doesn't work.

Steps to Reproduce:
1. Right-click a file in Nautilus
2. Select Send to..., then Bluetooth
3. Wait for dialog to detect your device
4. Click Send
5. Accept incoming file transfer on your device (in my case a Nokia 6280)

  
Actual results:
Error message appears reading "Unable to read file
'file:///home/djst/Desktop/testfile.txt'."

Additional info:
[djst@localhost ~]$ uname -a
Linux localhost.localdomain 2.6.18-1.2747.fc6 #1 SMP Fri Oct 6 17:57:33 EDT 2006
i686 i686 i386 GNU/Linux
Comment 1 David Woodhouse 2006-10-11 02:36:21 EDT
nautilus-sendto-bluetooth invokes gnome-obex-send with a file:/ URL.
But gnome-obex-send just expects a filename, not a URL. 

Reassigning to nautilus-sendto.
Comment 2 Alexander Larsson 2006-10-11 14:39:43 EDT
Upstream as:
http://bugzilla.gnome.org/show_bug.cgi?id=361520
Comment 4 Kevin R. Page 2006-11-12 09:42:11 EST
Still present in FC6 release with updates applied as of 2006-11-12.

Effectively means that files can't be sent using bluetooth without dropping to
the command line and using gnome-obex-send.
Comment 5 Bastien Nocera 2007-03-05 20:22:51 EST
You need at least version 0.8 of gnome-bluetooth for nautilus-sendto to work
properly with URIs. They were both released at around the same time, but
nautilus-sendto got updated, not gnome-bluetooth...
Comment 6 Harald Hoyer 2007-03-06 08:10:56 EST
should work with the gnome-bluetooth update I made..
Comment 7 Matthew Miller 2007-04-06 14:14:43 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 8 Kevin R. Page 2007-05-04 11:07:22 EDT
Works for me now; FC6 gnome-bluetooth-0.7.0-11.fc6, nautilus-sendto-0.7-5.fc6,
nautilus-sendto-bluetooth-0.7-5.fc6
Comment 9 Matthias Clasen 2007-10-02 01:24:42 EDT
Ok, closing then.

Note You need to log in before you can comment on or make changes to this bug.