RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 2102535 - [FIPS lab review] self-test
Summary: [FIPS lab review] self-test
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 9
Classification: Red Hat
Component: openssl
Version: 9.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: rc
: ---
Assignee: Clemens Lang
QA Contact: Hubert Kario
URL:
Whiteboard:
Depends On:
Blocks: 2112978
TreeView+ depends on / blocked
 
Reported: 2022-06-30 07:29 UTC by Dmitry Belyavskiy
Modified: 2023-06-05 15:54 UTC (History)
3 users (show)

Fixed In Version: openssl-3.0.1-39.el9_0
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 2112978 (view as bug list)
Environment:
Last Closed: 2023-06-05 15:54:47 UTC
Type: Bug
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openssl openssl pull 18834 0 None open Add digest_sign/_verify on-demand selftest 2022-07-20 14:31:05 UTC
Red Hat Issue Tracker CRYPTO-7878 0 None None None 2022-07-12 12:22:24 UTC
Red Hat Issue Tracker RHELPLAN-126697 0 None None None 2022-06-30 07:56:38 UTC

Description Dmitry Belyavskiy 2022-06-30 07:29:40 UTC
- self_test_sign

- the signature generation / verification should be done on a full message and not a pre-computed digest.

- rsa_enc_params should have one allowed padding mode (TBC)

- st_kat_kas_tests:
- DH: The self test looks like it uses an arbitrary PQG set. Considering the previous round, we only validated safeprimes (MODP, FFDHE) - please have a self test with one of those

Comment 1 Clemens Lang 2022-07-12 10:54:44 UTC
As confirmed by the lab, rsa_enc_params should use OAEP padding.

Comment 10 Clemens Lang 2023-06-05 15:54:47 UTC
RHEL 9.1 contains openssl-3.0.1-43.el9_0.


Note You need to log in before you can comment on or make changes to this bug.