Bug 210256 - Default monitor resolution too high 1680x1050 (or 1920x1080)
Default monitor resolution too high 1680x1050 (or 1920x1080)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
9
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Adam Jackson
bzcl34nup
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-10 20:46 EDT by Glenn Rottingen
Modified: 2008-08-11 12:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-11 12:22:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log where X is defaulting to bad resolution (66.47 KB, text/plain)
2006-11-14 08:29 EST, n0dalus
no flags Details
Xorg log from F7test4 LiveCD (67.16 KB, text/plain)
2007-05-02 10:08 EDT, n0dalus
no flags Details

  None (edit)
Description Glenn Rottingen 2006-10-10 20:46:11 EDT
Description of problem: Install of FC6pre x86-64 on ASUS P5VDC-MX motherboard
with VIA vt2851 chipset. VIA UnChrome PRO 1GP video. Came up with a 1680x1050
resolution.  This did not work on my LG1970 LCD monitor and also was to high for
my Phiips109.  Default resolution should be 800x600 or lower. Can always up the
resolution latter.


Version-Release number of selected component (if applicable):


How reproducible:  Install twice same problem.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Glenn Rottingen 2006-10-25 13:10:08 EDT
Same problem with FC6 10/24 release.  Hsink and vsink are out of range of Monitor.  
LD HL1970.

Rescue Boot and add Modes "800x600" to screen in xorg.conf allows me to continue.

1024x768 would most likely  also work.

After I'm up and running, I can change the resoultion 
Comment 2 n0dalus 2006-11-14 08:26:22 EST
I am having a similar problem with a freshly installed FC6, even after updates.
X starts in 1920x1080, which is not very readable, and is a completely wrong
aspect ratio for my 4:3 monitor.

Monitor: Philips 109S(4)

Using xorg-x11-server-Xorg-1.1.1-47.fc6.i386.rpm

Will attach Xorg log.
Comment 3 n0dalus 2006-11-14 08:29:32 EST
Created attachment 141149 [details]
Xorg log where X is defaulting to bad resolution
Comment 4 Glenn Rottingen 2007-01-16 10:33:10 EST
This problem is resolved.

I have create a new release of FC6 (pungi) 1/15/2008, i386.  Had no pbolem with
the monitor, default resolution was 1280x1024.

Thanks
Comment 5 Adam Jackson 2007-03-29 12:02:23 EDT
Marking resolve as per comment #4.
Comment 6 n0dalus 2007-05-02 10:02:39 EDT
Problem seems to still be happening -- using F7test4 LiveCD. Reopening.

Resolution is 1920x1080 on my 19" monitor, which is completely unusable.

Will attach new X log.

Should this be a blocker for F7?
Comment 7 n0dalus 2007-05-02 10:08:30 EDT
Created attachment 153946 [details]
Xorg log from F7test4 LiveCD
Comment 8 Bug Zapper 2008-04-03 14:28:33 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 9 Mark McClelland 2008-04-22 07:20:30 EDT
Please keep this bug open. I ran into this problem in F9 Beta with a Radeon
9600. The default resolution in GDM and GNOME was 1920x1080@60Hz, which my CRT
can't handle. Even if could do that resolution it would still be the wrong
aspect. I don't understand why X is trying to use a resolution that isn't
specified by DDC. I can supply my log if needed.
Comment 10 Bug Zapper 2008-05-13 22:24:48 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Adam Jackson 2008-08-11 12:22:11 EDT
This was caused by having some rather unlikely large modes in the mode pool.  I've removed most of them now on the basis that we shouldn't second-guess the monitor.  Please reopen if this is still an issue for you in F10.

Note You need to log in before you can comment on or make changes to this bug.