Bug 2103637 - tiled: FTBFS in Fedora Rawhide: Hardcodes x86_64 in the spec, fails on other architectures
Summary: tiled: FTBFS in Fedora Rawhide: Hardcodes x86_64 in the spec, fails on other ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: tiled
Version: 37
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Erik Schilling
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: BetaFreezeException, F37BetaFreezeException PYTHON3.11 F37FTBFS F38FTBFS, RAWHIDEFTBFS
TreeView+ depends on / blocked
 
Reported: 2022-07-04 10:08 UTC by Tomáš Hrnčiar
Modified: 2022-09-02 22:27 UTC (History)
7 users (show)

Fixed In Version: tiled-1.9.1-1.fc37
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-09-02 22:27:01 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2022-07-04 10:08:59 UTC
Description of problem:
Package tiled fails to build from source in Fedora Rawhide.

Version-Release number of selected component (if applicable):
1.8.4-2.fc37

Steps to Reproduce:
koji build --scratch f37 tiled-1.8.4-2.fc37.src.rpm

Additional info:
/builddir/build/BUILD/tiled-1.8.4/translations/translations.qbs:3:1 Error while handling product 'translations':
/builddir/build/BUILD/tiled-1.8.4/translations/translations.qbs:3:1 Profile 'x86_64-redhat-linux-gcc' does not exist.

Comment 1 Artur Frenszek-Iwicki 2022-07-04 11:30:47 UTC
Trying to build this in mock, the current spec fails even on x86_64,
since qbs reports that is has a "x86_64-redhat-linux-gcc-12" profile (note the "-12" at the end),
so when asked to use "x86_64-redhat-linux-gcc", it fails because no such profile was found.

Calling "qbs setup-toolchains --detect" automatically selects a profile, and it seems to always be the gcc one,
so it should be safe to just drop the "qbs config defaultProfile ..." line from the spec.

Trying to perform a mockbuild with the line removed, it fails with the following error:

ERROR: In file included from /usr/include/qt5/QtQml/5.15.4/QtQml/private/qqmldata_p.h:54,
                 from /builddir/build/BUILD/tiled-1.8.4/src/tiled/editablemanager.cpp:37:
/usr/include/qt5/QtQml/5.15.4/QtQml/private/qtqmlglobal_p.h:54:10: fatal error: QtCore/private/qglobal_p.h: No such file or directory
   54 | #include <QtCore/private/qglobal_p.h>
      |          ^~~~~~~~~~~~~~~~~~~~~~~~~~~~
compilation terminated.

Comment 2 Ben Cotton 2022-08-09 13:19:53 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 37 development cycle.
Changing version to 37.

Comment 4 Fedora Update System 2022-08-30 09:56:02 UTC
FEDORA-2022-f8e35be44d has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-f8e35be44d

Comment 5 Adam Williamson 2022-09-02 17:13:21 UTC
+4 in https://pagure.io/fedora-qa/blocker-review/issue/879 , marking accepted.

Comment 6 Fedora Update System 2022-09-02 22:27:01 UTC
FEDORA-2022-f8e35be44d has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.