Bug 210366 - ejabberd logrotate buglet
ejabberd logrotate buglet
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: ejabberd (Show other bugs)
5
noarch Linux
medium Severity medium
: ---
: ---
Assigned To: Jeffrey C. Ollie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-11 14:03 EDT by Jérôme Benoit
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-11 16:37:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to /etc:logrotate.d/ejabberd (637 bytes, text/x-patch)
2006-10-11 14:13 EDT, Jérôme Benoit
no flags Details

  None (edit)
Description Jérôme Benoit 2006-10-11 14:03:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.0.7) Gecko/20060913 Fedora/1.5.0.7-1.fc5 Firefox/1.5.0.7 pango-text

Description of problem:
log rotation in not done properly because of a bugglet in /etc/logrotate.d/ejabberd

Version-Release number of selected component (if applicable):
1.1.2

How reproducible:
Always


Steps to Reproduce:
1. just run /etc/cron.daily/logrotate
2.
3.

Actual Results:
/etc/cron.daily/logrotate:

sh: -c: line 1: unexpected EOF while looking for matching `"'
sh: -c: line 2: syntax error: unexpected end of file
error: error running postrotate script for /var/log/ejabberd/ejabberd.log /var/log/ejabberd/sasl.log

Expected Results:
log rotation of ejabberd log just be done with restart

Additional info:
juste do as a post rotate script :

runuser -s /bin/bash - ejabberd -c "erl -pa /usr/lib/ejabberd-1.1.2/ebin -noinput -sname ejabberdctl -s ejabberd_ctl -extra ejabberd@`hostname -s` reopen-log" >/dev/null 2>/dev/null || true

instead of  

runuser -s /bin/bash - ejabberd -c "erl -pa /usr/lib/ejabberd-1.1.2/ebin -noinput -sname ejabberdctl -s ejabberd_ctl -extra ejabberd@`hostname -s` reopen-log >/dev/null 2>/dev/null || true (without closing " tag woth runsuer ..
Comment 1 Jérôme Benoit 2006-10-11 14:13:39 EDT
Created attachment 138265 [details]
patch to /etc:logrotate.d/ejabberd
Comment 2 Jérôme Benoit 2006-10-11 14:17:11 EDT
Tired ... a lot of typos in my bug report but the patch just be OK.
Comment 3 Jérôme Benoit 2006-10-11 14:22:00 EDT
... should just be ... (really tired:/)
Comment 4 Jeffrey C. Ollie 2006-10-11 16:37:55 EDT
Thanks for the patch.  Fix in the next release.

Note You need to log in before you can comment on or make changes to this bug.