Bug 2103709 - Garbled Bluetooth headset microphone audio after upgrade to pipewire 0.3.53-2
Summary: Garbled Bluetooth headset microphone audio after upgrade to pipewire 0.3.53-2
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: pipewire
Version: 36
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Wim Taymans
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-07-04 15:16 UTC by Edson Dino Salvati
Modified: 2022-07-11 08:09 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-07-11 08:09:36 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Edson Dino Salvati 2022-07-04 15:16:05 UTC
Description of problem:
Garbled Bluetooth headset microphone audio after upgrade to pipewire 0.3.53-2. Downgrading to version 0.3.49-1 solves the problem. Tested with two different Bluetooth headsets.

Version-Release number of selected component (if applicable):
pipewire-0.3.53-2.fc36.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Record or make a call with microphone from Bluetooth headset.

Actual results:
Audio from microphone garbled and chopped. Audio reproduction works fine.

Expected results:
Microphone audio clear.

Additional info:
Using mSBC codec.

Comment 1 Stan Trzmiel 2022-07-05 12:27:00 UTC
Same here, update to pipewire 0.3.53-1 breaks audio recording with bluetooth headset. Tested on two different headsets (Jabra BT 2046 and Sony Wl-C310) on Skype and Teams.

SYSTEM: Fedora 36 X86_64
DE: KDE 5.25.5-1

steps to reproduce
 - turn on bluetooth and connect headset
 - make sure both microphone and headphones are set as default audio in/out
 - launch skype/teams
 - make test call and record message.

actual result:
  - recorded message is garbled (like it's missing frames)

expected result:
  - replayed message sounds clean without any distortion

Last known good version: pipewire-0.3.52.-4

Update to  0.3.53-4 (available in koji) didn't solve that issue.

Comment 2 Scott Hamilton 2022-07-05 16:34:17 UTC
Have the same issue which seems to be tied from the update from pipewire.x86_64 0.3.52-4.fc36 to pipewire.x86_64 0.3.53-2.fc36. Bose 700 headset connected via bluetooth is having the same garbled microphone recording as listed in the original ticket.

Seems to only be tied to bluetooth microphones and not other types(laptop internal or USB microphones)

Comment 3 Wim Taymans 2022-07-05 16:36:17 UTC
upstream issue and fix https://gitlab.freedesktop.org/pipewire/pipewire/-/issues/2460

Comment 4 Archer Allstars 2022-07-05 16:56:54 UTC
I also experience this issue. I am using Fedora 36. Downgrading PipeWire to 0.3.49 fixed this issue for me (I don't have PipeWire 0.3.52 in Fedora repo).

For anyone on Fedora, you can downgrade PipeWire by:

sudo dnf downgrade pipewire

It will downgrade PipeWire to the previous version before the update, which is 0.3.49 on Fedora.

And when you update the system, you can prevent PipeWire from updating to this problematic version by:

sudo dnf -x pipewire update

This will exclude PipeWire from updating. Until the fix is landed on Fedora, please do not update the system in the GNOME Software for the time being, as it will update PipeWire along with other packages.

Comment 5 countbayes 2022-07-06 00:31:50 UTC
I also experienced this issue. I am using Fedora 36. Downgrading PipeWire to 0.3.49 also fixed the issue for me

Comment 6 Stan Trzmiel 2022-07-07 10:39:35 UTC
From my quick test it seems pipewire 0.3.54 from koji is much better, can anyone confirm?

Comment 7 Edson Dino Salvati 2022-07-07 14:29:20 UTC
(In reply to Stan Trzmiel from comment #6)
> From my quick test it seems pipewire 0.3.54 from koji is much better, can
> anyone confirm?

I can confirm. It seems that pipewire-0.3.54-1 solves the problem.

Comment 8 David Juran 2022-07-11 07:20:14 UTC
With pipewire-0.3.54-1 pushed to F36, is there a reason this Bz isn't closed?


Note You need to log in before you can comment on or make changes to this bug.