Bug 210381 - incorrect memset() call in back-ldbm/perfctrs.c
incorrect memset() call in back-ldbm/perfctrs.c
Status: CLOSED UPSTREAM
Product: 389
Classification: Community
Component: Directory Server (Show other bugs)
7.1
i386 Windows
medium Severity medium
: ---
: ---
Assigned To: Rich Megginson
Chandrasekar Kannan
:
Depends On:
Blocks: 389_1.3.0 690319
  Show dependency treegraph
 
Reported: 2006-10-11 15:20 EDT by Mark Smith
Modified: 2015-01-04 18:21 EST (History)
1 user (show)

See Also:
Fixed In Version: 389-ds-base-1.2.10.rc1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 11:11:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark Smith 2006-10-11 15:20:17 EDT
In back-ldbm/perfctrs.c in the init_shared_memory() function, memset() is called
with the 2nd and 3rd parameters reversed:

  memset(perf,sizeof(performance_counters),0);

It looks like init_shared_memory() is only called on Windows (where the
performance counters reside in shared memory instead of process memory).  I am
not sure if this causes any problems or not; perhaps the memory is cleared
elsewhere.

I found this using Google code search in someone's tarball of Fedora DS 1.02 and
then I confirmed this still exists in the trunk code by using lxr.
Comment 1 Martin Kosek 2012-01-04 08:48:16 EST
Upstream ticket:
https://fedorahosted.org/389/ticket/140
Comment 2 Rich Megginson 2012-02-07 11:11:21 EST
Fixed in 389-ds-base-1.2.10.rc1 now in Fedora/EPEL Testing

Note You need to log in before you can comment on or make changes to this bug.