Bug 210416 - mkdumprd won't abort even if an error occurs.
mkdumprd won't abort even if an error occurs.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kexec-tools (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Neil Horman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-11 18:04 EDT by Akira Imamura
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-13 12:14:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This patch can fix the problem. (1010 bytes, patch)
2006-10-11 18:04 EDT, Akira Imamura
no flags Details | Diff

  None (edit)
Description Akira Imamura 2006-10-11 18:04:43 EDT
Description of problem:
mkdumprd won't abort even if it fails to unmount of a temporary
directory for testing of NFS path.

Version-Release number of selected component (if applicable):
kexec-tools-1.101-92.el5

How reproducible:
Always

Steps to Reproduce:
1. Configure "net" in /etc/kdump.conf so that it fails to mount the specified
nfs path.
2. Run "service kdump restart"
3.
  
Actual results:
kdump starts up.

Expected results:
kdump fails to start up with warning.


Additional info:
The cause of this problem is that mkdumprd doesn't check a return value of
umount. I attached a patch to fix this problem.
Comment 1 Akira Imamura 2006-10-11 18:04:45 EDT
Created attachment 138288 [details]
This patch can fix the problem.
Comment 2 Neil Horman 2006-10-12 07:58:01 EDT
fixed in -93.el5.  Thanks!
Comment 3 Jay Turner 2007-02-13 12:14:08 EST
kexec-tools-1.101-164.el5 included in 20070208.0.

Note You need to log in before you can comment on or make changes to this bug.