Bug 21047 - RH7 does not run Quake or Quake II
RH7 does not run Quake or Quake II
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-18 04:09 EST by Need Real Name
Modified: 2016-11-24 10:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-18 04:09:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-11-18 04:09:34 EST
RH6.2 did run quake and quake2 just fine, but when I installed
RH7, these do not start any more. I took a tar before RH7 install,
and installed RH7/Gnome to an empty disk, and restored the
tar file, i.e. quake and quake2 directories under /usr/games.

I asked this in alt.os.linux and comp.os.linux.misc newsgroups,
but did not find a solution, Thomas "ZlatkO" Zajic  <zlatko@gmx.at>
suggested that this happens because RH7 contais development
matority components, such as glibc-2.1.92 or glibc-2.1.94-3.

Please help!

-Paavo (paavo.leinonen@wipsl.com)

$ ./squake
bash: ./squake: No such file or directory
$ ll ./squake
-rwxr-xr-x    1 root     root       438376 Aug  8  1997 ./squake
$ ./squake
bash: ./squake: No such file or directory
$ file ./squake
./squake: ELF 32-bit LSB executable, Intel 80386, version 1, dynamically linked (uses shared libs), not stripped
$ pwd
/usr/games/quake1
$ /usr/games/quake1/squake
bash: /usr/games/quake1/squake: No such file or directory
$ ll /usr/games/quake1/squake
-rwxr-xr-x    1 root     root       438376 Aug  8  1997 /usr/games/quake1/squake
$ file /usr/games/quake1/squake
/usr/games/quake1/squake: ELF 32-bit LSB executable, Intel 80386, version 1, dynamically linked (uses shared libs), not stripped

------------------------------------------------------------------------------------

Subject: 
             Re: Redhat 7 won't run quake/quake2
        Date: 
             Sun, 15 Oct 2000 07:11:52 GMT
       From: 
             Paavo Leinonen <paavo.leinonen@wipsl.com>
 Organization: 
             HOPnet, Oulu, Finland
  Newsgroups: 
             comp.os.linux.misc
   References: 
             1 , 2 , 3 , 4




Hi,

glibc-2.1.94-3 was available through update agent, I took that,
but it didn't help. What are my options?

- go back to RH6.2 or some other, more stable distro?
- wait RH7 to get better (RH6.2 did run quake 1&2 fine)?
- get rid of faulty libs and replace those with food ones?
- something else? Good suggestions welcome!

First one does not look good, I've just installed an X-terminal,
too, and I'm not too eager to configure *everything* again.

Third one is a scary one, too, I'm not that familiar with Linux,
and I'm a bit afraid that changing something like glibc might
broke something else, quake (1) and quake 2 servers are not the
most important things to run you might guess...

So waiting RH7 to become more reliable is what I'll do?

-Paavo

Thomas Zajic wrote:
> 
> On Wed, 11 Oct 2000 19:08:39 GMT, Paavo Leinonen wrote:
> 
> > glibc 2.1.92 is installed (it was part of the default Gnome-
> > workstation install), but I have not done any configuration
> > to use glibc instead of libc's. What should I do? RTFM? :)
> 
> Ouch, that's a development version - I've had some problems with it
> at work, too (Debian 2.2 unstable (Woody?)). The new ld/ld.so wouldn't
> load the game .so's from Q3A Rocket Arena 3 v1.3, so I had to downgrade
> our RA3 server to v1.0 (mySlack 7.0 at home with glibc-2.1.2 loads &
> runs RA3 v1.3 just fine).
> 
> Unfortunately I haven't found a way yet to back out unstable packages
> that don't work properly. I'm tempted to remove the unstable branches
> in /etc/apt/sources.list, 'apt-get update', and then 'apt-get --reinstall
> install libc6 ldso', but libc6 and ld.so are probably not the best
> packages to start experimenting with. Any experienced Debian users out
> there who know the right way?
> 
> Thomas
> --
> =-------------------------------------------------------------------------=
> -  Thomas "ZlatkO" Zajic  <zlatko@gmx.at>   Linux-2.2.17/slrn-0.9.6.3pl1  -
> -  "It is not easy to cut through a human head with a hacksaw."  (M. C.)  -
> =-------------------------------------------------------------------------=
Comment 1 Jakub Jelinek 2000-11-18 15:28:24 EST
This has nothing to do with glibc (and btw we're just testing
glibc-2.2 errata packages which are latest stable glibc release).
It looks like quake is libc5 application, and libc5 is no longer
supported in RH7. If you want to run such applications, you can
install ld.so and libc5 packages from RH6.2 on your RH7 system.

Note You need to log in before you can comment on or make changes to this bug.