Bug 210482 - RFE: flag for clusvcadm to respect failover domain priorities
RFE: flag for clusvcadm to respect failover domain priorities
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: rgmanager (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
Cluster QE
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-12 10:42 EDT by Nils Philippsen
Modified: 2009-04-16 16:21 EDT (History)
5 users (show)

See Also:
Fixed In Version: RHBA-2007-0149
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-10 17:18:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Implements behavior (7.29 KB, patch)
2007-01-04 10:46 EST, Lon Hohberger
no flags Details | Diff

  None (edit)
Description Nils Philippsen 2006-10-12 10:42:07 EDT
Description of problem:
SSIA, instead of what is specified in /etc/cluster/cluster.conf, "clusvcadm -e
<service>" starts <service> on the local node.

Version-Release number of selected component (if applicable):
rgmanager-1.9.53

How reproducible:
Easy

Steps to Reproduce:
1. "clusvcadm -e <service>"
  
Actual results:
<service> gets started on local node

Expected results:
<service> should be started on a node in the cluster that satisfies constraints
specified in cluster.conf, e.g. priority.

Additional info:
Comment 1 Lon Hohberger 2006-10-17 10:23:36 EDT
Expected behavior.  Use the -n <nodename> flag.  You can use clusvcadm to
explicitly start the service where you want, otherwise, the assumption is that
the service should be started locally.

The failover domain priority is used for cluster-induced service transitions
(which happen after node transitions), and is not used for user-induced
enable/disable requests.

It may be possible to add a flag to clusvcadm to do this (for 'use failover
domain priority, if possible') in a future release, but the current behavior is
not a bug.

However, the basic behavior for '-e' is correct.



Comment 2 Nils Philippsen 2006-10-17 11:44:58 EDT
This should be mentioned in "clusvcadm --help" somewhere, the people I've
encountered seem to expect "clusvcadm" to respect the constraints in
cluster.conf when using "-e". Should I open a new BZ item for an RFE?
Comment 3 Lon Hohberger 2006-10-18 12:00:26 EDT
Yes, please do.
Comment 4 Lon Hohberger 2006-10-18 12:01:13 EDT
Or we can use this one... *shrug*
Comment 5 Lon Hohberger 2007-01-04 10:46:33 EST
Created attachment 144808 [details]
Implements behavior

clusvcadm -Fe <service>
Comment 6 Lon Hohberger 2007-01-04 10:48:31 EST
Tested with a service with an ordered failover domain; worked for me.  This
option can not be used with the -[nm] flag.
Comment 7 Lon Hohberger 2007-01-04 10:52:59 EST
Patches in CVS
Comment 10 Red Hat Bugzilla 2007-05-10 17:18:24 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0149.html

Note You need to log in before you can comment on or make changes to this bug.