Bug 210501 - there should be a easy way to once and for all disable makewhatis
there should be a easy way to once and for all disable makewhatis
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: man (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Ben Levenson
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-12 11:59 EDT by Thorsten Leemhuis
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-27 04:40:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thorsten Leemhuis 2006-10-12 11:59:03 EDT
Description of problem:
I don't need makewhatis, but I can't easily deactive it's cron job (modifing
stuff in /etc/cron.*/ does not count IMHO because that's ugly) -- that's really
annoying because it creates hard-disk and CPU load now and then that's wasted in
my eyes, creates noise and consumes power.

There could be two easy solutions afaics:

- create a seperate subpackage for whatis that gets installed by default. I can
then simply delete it and everything is fine for everyone
- pjones suggested in #fedora-devel that the above seems like a mediocre
solution to him. pjones further: "why not just have an
"/etc/sysconfig/makewhatis" that tells the job whether to actually do anything
or not"
Comment 1 Ivana Varekova 2006-10-24 05:06:01 EDT
This problem sould be solved by editing cron jobs. There is no need to add new
option to disable/enable makewhatis script.
Comment 2 Thorsten Leemhuis 2006-10-24 05:14:54 EDT
(In reply to comment #1)
> This problem sould be solved by editing cron jobs. There is no need to add new
> option to disable/enable makewhatis script.

Enabling cron jobs has several disadvantages 
- the modified files may get overwritten on each update
- if the files are marked correctly and %config in the spec file then rpm will
place a .rpmnew file in the proper place on each update. People like me, that
periodically scan there filesystem for rpmnew files have to look at those file
each time. That sucks.

Reopening. BTW, I can provide a patch to fix this. Just tell me what solution
you might prefer (see first comment in this bug).
Comment 3 Ivana Varekova 2006-10-27 04:40:22 EDT
Your argument seems very reasonably. 
The option (MAKEWHATISDBUPDATES) was added to man.config file - patch is in
man-1.6d-3.
If there is any problem with this option please reopen this bug. 

Note You need to log in before you can comment on or make changes to this bug.