Bug 210512 - Keyboard does not work. fc6pre
Keyboard does not work. fc6pre
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-12 12:34 EDT by DM Smith
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: FC6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-25 10:56:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Installation log from anaconda (132.91 KB, text/plain)
2006-10-19 16:57 EDT, Sebastian Vahl
no flags Details
Ins (ups. pressed enter too early. please ignore or delete this) (23.71 KB, application/octet-stream)
2006-10-19 16:58 EDT, Sebastian Vahl
no flags Details
Installation log from anaconda (syslog) (23.71 KB, text/plain)
2006-10-19 16:58 EDT, Sebastian Vahl
no flags Details
Installation log from anaconda (xlog) (44.46 KB, text/plain)
2006-10-19 17:03 EDT, Sebastian Vahl
no flags Details
dmesg from first boot (18.40 KB, text/plain)
2006-10-19 17:05 EDT, Sebastian Vahl
no flags Details
messages from first boot (30.93 KB, text/plain)
2006-10-19 17:06 EDT, Sebastian Vahl
no flags Details

  None (edit)
Description DM Smith 2006-10-12 12:34:12 EDT
Description of problem:
During the first boot of FC6 pre, I am unable to use the keyboard to tab from
field to field, to add a time server, or to enter a new user on "Create User".

The keyboard seems to be dead.

Note, earlier during install I was able to use the keyboard.

If I finish first boot without creating a user, the keyboard then works just
fine on the login screen and afterward.

Version-Release number of selected component (if applicable):
What ever is in fc6pre

How reproducible:
Always on my hardware.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Toshiba Tekra S2.
Comment 1 Chris Lumens 2006-10-12 13:15:25 EDT
What keyboard layout are you using?
Comment 2 Chris Lumens 2006-10-12 13:32:44 EDT
Actually, please upgrade to firstboot-1.4.23-1, rm /etc/sysconfig/firstboot,
reboot and see if it is fixed for you.  I believe firstboot-1.4.22-1 was in
FC6pre (rpm -q firstboot to find out) and if so, this is most likely fixed up. 
I wasn't able to get that version finished in time for the prerelease.
Comment 3 DM Smith 2006-10-12 14:14:02 EDT
I am using US English, which I chose during install. The keyboard model is
"Generic 105-key (Intl) PC" this was picked for me.

I installed firstboot-1.4.23.1. The /etc/sysconfig/firstboot file did not exist.
Rebooted. Same results.

However I did notice that if I hit return at any point during the install,
firstboot would go away and I'd be left at the login screen.

Again, once I am at the login screen the keyboard works just fine.
Comment 4 Sebastian Vahl 2006-10-18 13:40:05 EDT
I have this problem too. On the mailinglist I was asked too report it here. So
here we go:

Some infos about the installation:

- Installationmethod: DVD (FC-6-Pre-i386-DVD)
- Changed options in anaconda:
* Keyboardlayout: german with nodeadkeys
* changed partition scheme (no lvm)
* installed grub in /dev/hdb1 (not /dev/hda) and deleted "Other"
* no UTC in clock
* only unchecked "Office & Productivity" in packages

Some infos about my hardware:
- CPU: Athlon XP 2400+
- Mainboard: MSI KT4AV (VIA KT400)
- RAM: 2x512 MB (1x Infineon, 1x TakeMS)
- VGA: MSI Geforce 4 Ti 4200
- Keyboard: A4Tech iKeyWorks Office (KBS-8)
- Monitor: Samtron 76E


During my tests the problem occured every time when booting with the normal
grub.conf (with rhgb). I've installed FC6Pre today 5-8 times (not sure):
No keyboard available in firstboot (cannot even switch to STRG+ALT+F1 to see
some errors). Pressing enter kills firstboot and starts gdm. In gdm keyboard
works again.


How the problem could be workarounded:

1. disable rhgb in grub.conf
2. Update to newest rhgb
3. disable selinux for rhgb in system-config-security and reboot (!)

Even when I upgrade to newest rhgb and downgrade it to FC6Pre-Version the
problem disappears. So I think, this is a problem with selinux and rhgb, not
firstboot. I've also had some graphic problems with rhgb and gdm which also
disappeard when using one of the three steps above.
Comment 5 Sebastian Vahl 2006-10-18 16:28:04 EDT
Just two additional notes:

- disc check and sha1sum for dvd are ok
- relabeling the filesystem for selinux don't solve the problem
Comment 6 Chris Lumens 2006-10-19 14:52:52 EDT
I believe there were some problems with rhgb, selinux, and X keyboards that were
discovered right before FC6 and hopefully fixed before the release.  Please try
again with FC6 final and let me know if this is still happening.  I know that's
a pretty lame answer, but I'm not having any luck reproducing this over here and
therefore I don't know what to do about it.  Thanks.
Comment 7 Sebastian Vahl 2006-10-19 16:57:03 EDT
Created attachment 138908 [details]
Installation log from anaconda
Comment 8 Sebastian Vahl 2006-10-19 16:58:29 EDT
Created attachment 138909 [details]
Ins
(ups. pressed enter too early. please ignore or delete this)
Comment 9 Sebastian Vahl 2006-10-19 16:58:40 EDT
Created attachment 138910 [details]
Installation log from anaconda (syslog)
Comment 10 Sebastian Vahl 2006-10-19 17:03:09 EDT
Created attachment 138913 [details]
Installation log from anaconda (xlog)
Comment 11 Sebastian Vahl 2006-10-19 17:05:31 EDT
Created attachment 138915 [details]
dmesg from first boot
Comment 12 Sebastian Vahl 2006-10-19 17:06:24 EDT
Created attachment 138916 [details]
messages from first boot
Comment 13 Sebastian Vahl 2006-10-19 17:10:07 EDT
Attached the logs from one installation. I don't see anything but perhaps you do.

How I created this logs:
1. Installed FC6Pre (description is in #4)
2. Booted into installation
3. Pressed enter to kill firstboot
4. Logged in gdm into gnome and saved the logs
Comment 14 Sebastian Vahl 2006-10-24 13:04:31 EDT
Seems to be fixed in FC6Final (at least for me).
Comment 15 DM Smith 2006-10-25 10:36:01 EDT
Works for me too in fc6final. Thanks!
Comment 16 Chris Lumens 2006-10-25 10:56:46 EDT
Closing based on previous comments.  Hooray.

Note You need to log in before you can comment on or make changes to this bug.