Bug 210525 - stellarium seg fault on AMD 64bit
stellarium seg fault on AMD 64bit
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: stellarium (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jochen Schmitt
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: FE7Target
  Show dependency treegraph
 
Reported: 2006-10-12 14:35 EDT by Rick Richardson
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-14 18:15:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace for stellarium segfault (101.11 KB, text/plain)
2006-11-12 12:19 EST, Marc Bradshaw
no flags Details
PATCH fixing the crash due to using OpenGL without an OpenGL context (964 bytes, patch)
2006-11-13 17:19 EST, Hans de Goede
no flags Details | Diff
PATCH: correct 64 bit fix (469 bytes, patch)
2006-11-13 17:19 EST, Hans de Goede
no flags Details | Diff

  None (edit)
Description Rick Richardson 2006-10-12 14:35:05 EDT
$ stellarium
 -------------------------------------------------------
[ This is Stellarium 0.8.2 - http://www.stellarium.org ]
[ Copyright (C) 2000-2006 Fabien Chereau et al         ]
 -------------------------------------------------------
Segmentation fault
$

$ uname -a
Linux amd.rkkda.org 2.6.17-1.2187_FC5 #1 SMP Mon Sep 11 01:16:59 EDT 2006 x86_64
x86_64 x86_64 GNU/Linux
Comment 1 Jochen Schmitt 2006-10-15 15:30:56 EDT
On
 
http://sourceforge.net/tracker/index.php?func=detail&aid=1566760&group_id=48857&atid=454373

I have found a patch which should solve the reported problem. Becouse I haven't
a 64 bit system, it will be nice, if anyone can test the new build package and
notify me about the result of the test.
Comment 2 Jochen Schmitt 2006-11-09 13:39:49 EST
Becouse I have not got any feedback, I assume, that the patch will be OK, so I
can close this bug.
Comment 3 Rick Richardson 2006-11-09 15:07:10 EST
I can't do patches - binary only!!!!
Comment 4 Rick Richardson 2006-11-09 15:32:32 EST
$ rpm -q stellarium
stellarium-0.8.2-1.fc5.2

http://fedoraproject.org/extras/5/x86_64/repodata/repoview/stellarium-0-0.8.2-1.fc5.2.html

$ stellarium
 -------------------------------------------------------
[ This is Stellarium 0.8.2 - http://www.stellarium.org ]
[ Copyright (C) 2000-2006 Fabien Chereau et al         ]
 -------------------------------------------------------
Segmentation fault (core dumped)
Comment 5 Marc Bradshaw 2006-11-12 12:19:05 EST
Created attachment 140995 [details]
strace for stellarium segfault

strace output for stellarium segfault
Comment 6 Marc Bradshaw 2006-11-12 12:20:29 EST
problem also exists on i686

[root@daisy ~]# uname -a
Linux daisy.lan 2.6.18-1.2798.fc6 #1 SMP Mon Oct 16 14:37:32 EDT 2006 i686 
i686 
i386 GNU/Linux


[root@daisy ~]# stellarium
 -------------------------------------------------------
[ This is Stellarium 0.8.2 - http://www.stellarium.org ]
[ Copyright (C) 2000-2006 Fabien Chereau et al         ]
 -------------------------------------------------------
Will create config files in /root/.stellarium/
Try to create directory /root/.stellarium/
Segmentation fault


[root@daisy ~]# rpm -q stellarium
stellarium-0.8.2-2.fc6
Comment 7 Marc Bradshaw 2006-11-12 12:38:17 EST
(In reply to comment #6)

problem is with nvidia drivers, please ignore.
Comment 8 Hans de Goede 2006-11-13 08:08:20 EST
Since the problem is with the nvidea drivers, I assume this bug can be closed?
Ifso then please close it. Or was the 32 bit / i686 problem with the nvidea driverS?
Comment 9 Jochen Schmitt 2006-11-13 15:04:58 EST
If you are sure, that is a nvidia problem, I will close this bug again.
Comment 10 Rick Richardson 2006-11-13 15:19:56 EST
Jeez!  Open this bug!
Comment 11 Hans de Goede 2006-11-13 16:38:09 EST
I can reproduce this on x86_64 with opensource dri drivers. I guess Jochen mis
understood me, I was trying to ask if Marc was sure this was to blame on the
NVidea drivers, not trying to state it was the dri drivers.

I'm looking into this now, it looks like a classic case of using OpenGL calls
before creating an OpenGL context.
Comment 12 Hans de Goede 2006-11-13 17:19:32 EST
Created attachment 141113 [details]
PATCH fixing the crash due to using OpenGL without an OpenGL context

Here is a patch fixing this crash.

Also the patch for the 64 bit issue which you took from sf.net is wrong! The
gentoo patch attached there is correct!

I'll attach it here too for your convinience.
Comment 13 Hans de Goede 2006-11-13 17:19:56 EST
Created attachment 141114 [details]
PATCH: correct 64 bit fix
Comment 14 Jochen Schmitt 2006-11-14 14:04:59 EST
I have create a package stellarium-0.8.2-3 for developement, FC-6 and FC-7.
Becouse I haven't a 64bit-system please test the package and notify me.
Comment 15 Hans de Goede 2006-11-14 18:15:12 EST
As I already wrote: "I can reproduce this on x86_64 with opensource dri
drivers", thus no surprise after building 0.8.2-3 from CVS, which contains my
fixes (which were alreayd tested on 64 bit) stellarium still works fine, iow
this is fixed, closing.

Note You need to log in before you can comment on or make changes to this bug.