Bug 210548 - [RHEL5 Beta2] anaconda/mkinitrd: difference of driver loading order between installation time and boot time after installation causes name changes.
[RHEL5 Beta2] anaconda/mkinitrd: difference of driver loading order between i...
Status: CLOSED DUPLICATE of bug 185852
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd (Show other bugs)
5.0
All Linux
high Severity high
: ---
: ---
Assigned To: David Cantrell
David Lawrence
: FutureFeature
Depends On:
Blocks: 228988 227613 230627
  Show dependency treegraph
 
Reported: 2006-10-12 15:58 EDT by Kiyoshi Ueda
Modified: 2009-06-19 05:25 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-13 17:27:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kiyoshi Ueda 2006-10-12 15:58:13 EDT
Description of problem:
Loading order of device drivers is different between installation time
and boot time after installation, even if HW configuration is unchanged.
(e.g. In one of our test environment,
        at installation, the order is qla2xxx, then mptscsih,
        after installation, the order is mptscsih, then qla2xxx.)

The difference causes device name changes, and the name changes
causes some problems.
For example:
  o System panic occurs during boot if the root filesystem is
    on a (dm) multipath device, because (dm) multipath map is
    created against specific major:minor combinations during boot.

  o /boot/efi partition isn't mounted by default on IA64 systems
    during boot, because /boot/efi is mounted by device name
    instead of label.


Version-Release number of selected component:
rel-eng/RHEL5-Server-20061006.2
    anaconda-11.1.0.108-1
    mkinitrd-5.1.19-1


How reproducible:
Always


Steps to Reproduce:
 1. Install mptscsih SCSI card, SCSI disk, qla2xxx FC card and FC disk
    to a IA64 box.
 2. Install OS.
    At the time, remember the driver loading order and which disk is
    which name, and assign /boot/efi on the SCSI disk.
 3. Reboot


Actual results:
Driver loading order is changed during boot, so device name of
the SCSI disk is changed.
As a result, /boot/efi isn't mounted during boot.


Expected results:
Driver loading order should not be changed as long as
HW configuration is not changed.


Additional info:
Comment 4 David Cantrell 2007-06-13 17:27:11 EDT
There are two bugs listed here.  The /boot/efi labeling problem is fixed in
RHEL-5.0 GA.  The multipath enumeration problem is a duplicate of 185852.

*** This bug has been marked as a duplicate of 185852 ***

Note You need to log in before you can comment on or make changes to this bug.